aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2020-04-17 15:03:07 +0300
committerSergey Poznyakoff <gray@gnu.org>2020-04-17 15:03:07 +0300
commit7673f245e3ea59d912b382ee9232bf5fbeb562f1 (patch)
treee4d01b6252c980a69d95070b5a8b20dc860534e2 /configure.ac
parent39cb043bf015b36819a9f431c386592c59480f92 (diff)
downloadwydawca-7673f245e3ea59d912b382ee9232bf5fbeb562f1.tar.gz
wydawca-7673f245e3ea59d912b382ee9232bf5fbeb562f1.tar.bz2
Improve configure.ac
* configure.ac: Check for librt and gpgme_set_offline.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f99f49f..0e1366b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,7 @@ AC_CONFIG_FILES([libltdl/Makefile])
AC_SUBST(WYDAWCA_MODDIR,'$(libdir)/$(PACKAGE)')
# Checks for libraries.
+AC_CHECK_LIB(rt, clock_gettime)
# Checks for header files.
AC_HEADER_STDC
@@ -62,7 +63,7 @@ AC_FUNC_STAT
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([fchdir setegid setregid setresgid setresuid seteuid \
setreuid vsyslog sysconf getdtablesize inotify_init])
-
+
# **********************
# Mailutils
# **********************
@@ -100,6 +101,16 @@ WY_CHECK_LIB([gpgme],[main],[],
[ AC_MSG_FAILURE([The requested library libgpgme is not found or is unusable])],
[/usr/pkg/lib /opt/lib /sw/lib])
+saved_LDADD=$LDADD
+LDADD="$LDADD $GPGMELIB"
+AC_CHECK_FUNC(gpgme_set_offline)
+AH_BOTTOM(
+[#ifndef HAVE_GPGME_SET_OFFLINE
+# define gpgme_set_offline(c,f)
+#endif
+])
+LDADD=$saved_LDADD
+
# **********************
# TCP wrappers
# **********************

Return to:

Send suggestions and report system problems to the System administrator.