aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-02-25 22:12:34 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2009-02-25 22:12:34 +0200
commit27d1256d331d45bf68d96e9a8aa8175df2584978 (patch)
treed4e28ce067fa001b7aff5a470c146a6d04eead96 /configure.ac
parentc9178a6fef0184baed0e8456bb6c6d4091b4997c (diff)
downloadwydawca-27d1256d331d45bf68d96e9a8aa8175df2584978.tar.gz
wydawca-27d1256d331d45bf68d96e9a8aa8175df2584978.tar.bz2
Check incoming connections using libwrap; various bugfixes.
* configure.ac: Check for libwrap. * src/tcpwrap.c: New file. * src/Makefile.am (wydawca_SOURCES): Add tcpwrap.c * src/builtin.c, src/job.c, src/pidfile.c: Minor fixes. * src/config.c (assert_string_arg): Change to extern. (wydawca_kw): New block statement "tcp-wrapper" * src/net.c (wydawca_listener): Check fd using libwrap. * src/triplet.c (DECL_EXPAND_TIMER): Add missing return statement.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f6eaa0..737e2dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,26 @@ WD_CHECK_LIB([gpgme],[main],[],
[/usr/pkg/lib /opt/lib /sw/lib])
# **********************
+# TCP wrappers
+# **********************
+AC_ARG_WITH(tcp-wrappers,
+ AC_HELP_STRING([--with-tcp-wrappers],
+ [compile with TCP wrappers support (default)]),
+ [status_tcpwrap=${withval}],
+ [status_tcpwrap=yes])
+
+if test "$status_tcpwrap" = yes; then
+ AC_CHECK_LIB(nsl, main)
+ AC_CHECK_LIB(wrap, main,, [status_tcpwrap=no])
+ if test "$status_tcpwrap" = yes; then
+ AC_CHECK_HEADERS(tcpd.h,,[status_tcpwrap=no])
+ fi
+fi
+if test "$status_tcpwrap" = yes; then
+ AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap])
+fi
+
+# **********************
# Preprocessor
# **********************
AC_ARG_WITH([preprocessor],

Return to:

Send suggestions and report system problems to the System administrator.