summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 12 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index ec97901..c6fb4a6 100644
--- a/setup.py
+++ b/setup.py
@@ -15,26 +15,29 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-from distutils.core import setup
-import wikimarkup
+from setuptools import setup, find_packages
+from codecs import open
-setup(name='wit',
+setup(name='wikitrans',
version='0.1',
author='Sergey Poznyakoff',
- author_email='gray@gnu.org.ua',
- url='http://gray.gnu.org.ua/',
- package_dir = {'wit': ''},
- packages=['wit'],
+ author_email='gray@gnu.org',
+ url='http://www.gnu.org.ua/projects/wit',
+# package_dir = {'src': ''},
+ packages = find_packages(exclude=['contrib', 'docs', 'tests*']),
+ scripts=['bin/wikitrans'],
license='GPL License',
description='Wiki markup translator.',
+ long_description='Translates MediaWiki documents markup to various other formats',
platforms=['any'],
classifiers=[
- 'Development Status :: 3 - Alpha',
+ 'Development Status :: 4 - Beta',
'Intended Audience :: Developers',
'License :: OSI Approved :: GNU General Public License (GPL)',
'Operating System :: OS Independent',
'Programming Language :: Python',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Text Processing :: Markup'
- ]
+ ],
+ keywords = 'mediawiki markup translation',
)

Return to:

Send suggestions and report system problems to the System administrator.