aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 2fa32f6..f21fcfb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,24 +108,6 @@ if test -z "$VMODDIR"; then
108 VMODDIR='$(libdir)/varnish/mods' 108 VMODDIR='$(libdir)/varnish/mods'
109fi 109fi
110 110
111###########
112# Check for db.h and libdb
113#
114AC_CHECK_HEADER([db.h],,[AC_MSG_ERROR([Required header file db.h not found])])
115
116AC_CHECK_LIB(db, db_create,
117 [LIBS="$LIBS -ldb"
118 AC_RUN_IFELSE(
119 [AC_LANG_PROGRAM([#include "db.h"],
120 [int v_major, v_minor, v_patch;
121 db_version(&v_major, &v_minor, &v_patch);
122 return !(v_major == DB_VERSION_MAJOR
123 && v_minor == DB_VERSION_MINOR
124 && v_patch == DB_VERSION_PATCH);
125 ])],
126 [],
127 [AC_MSG_ERROR([header file db.h is not the same version as libdb])])])
128
129AC_CONFIG_COMMANDS([status],[ 111AC_CONFIG_COMMANDS([status],[
130delim="-------------------------------------------------------------------" 112delim="-------------------------------------------------------------------"
131echo "" 113echo ""

Return to:

Send suggestions and report system problems to the System administrator.