aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-08-04 17:38:17 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2017-08-04 17:39:46 +0300
commite2e9e4647ae1baf3de116bc52f1f73b8cf221c76 (patch)
tree4c7f88a92aed8ebe28d1e0584737bbe9ec1d2689 /src/Makefile.am
parent9d9f34d1ef0483fc012ea283e649d507ff410638 (diff)
downloadvmod-variable-e2e9e4647ae1baf3de116bc52f1f73b8cf221c76.tar.gz
vmod-variable-e2e9e4647ae1baf3de116bc52f1f73b8cf221c76.tar.bz2
Switch to new acvmod
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 19 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5396773..bf5eee8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,27 +1,23 @@
-# This file is part of vmod-variable
-# Copyright (C) 2015, 2016 Sergey Poznyakoff
-#
-# Vmod-variable is free software; you can redistribute it and/or modify
+# This file is part of vmod_variable.
+# Copyright (C) 2017 Sergey Poznyakoff
+#
+# Vmod_variable is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
-#
-# Vmod-variable is distributed in the hope that it will be useful,
+#
+# Vmod_variable is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
-# along with vmod-variable. If not, see <http://www.gnu.org/licenses/>.
+# along with vmod_variable. If not, see <http://www.gnu.org/licenses/>.
AM_CPPFLAGS=\
- -I$(VARNISHSRC)/include\
- -I$(VARNISHSRC)/bin/varnishd\
- -I$(VARNISHSRC)\
+ $(VARNISHAPI_CFLAGS)\
-DLOCALSTATEDIR=\"$(localstatedir)\"
-dist_man_MANS=vmod-variable.3 vmod_variable.3
-
vmoddir = $(VMODDIR)
vmod_LTLIBRARIES = libvmod_variable.la
@@ -38,14 +34,20 @@ variable.lo: vcc_if.h
CLEANFILES = vcc_if.c vcc_if.h *.rst
-vmodtool = $(VARNISHSRC)/lib/libvcc/vmodtool.py
vmodtoolargs = --strict
vccfile = $(top_srcdir)/src/variable.vcc
-vcc_if.c vcc_if.h: $(vmodtool) $(vccfile)
- $(AM_V_GEN)$(PYTHON) $(vmodtool) $(vmodtoolargs) $(vccfile)
+vcc_if.c vcc_if.h: $(vccfile)
+ $(AM_V_GEN)$(PYTHON) $(VARNISHAPI_VMODTOOL) $(vmodtoolargs) $(vccfile)
EXTRA_DIST = \
- variable.vcc
+ variable.vcc\
+ vmod_variable.man.rst\
+ vmod_variable.rst
+
+dist_man_MANS=vmod_variable.3 vmod-variable.3
+
+DISTCLEANFILES=vmod_variable.3
+

Return to:

Send suggestions and report system problems to the System administrator.