aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 26 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4790115..0f90aa7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,17 +1,38 @@
1VMOD_VTC = \
2 test01.vtc\
3 test03.vtc\
4 time00.vtc
5
6VMOD_VTI = \
7 test00.vti\
8 test02.vti
9
10BUILT_TESTS = $(VMOD_VTI:.vti=.vtc)
11
1VMOD_TESTS = \ 12VMOD_TESTS = \
2 test00.vtc\ 13 test00.vti\
3 test01.vtc\ 14 test01.vtc\
4 test02.vtc\ 15 test02.vti\
5 test03.vtc\ 16 test03.vtc\
6 time00.vtc 17 time00.vtc
7 18
8EXTRA_DIST=$(VMOD_TESTS) 19.vti.vtc:
20 sed 's/^#VARNISH$(VARNISHVERSION)#//' $< > $@
21
22EXTRA_DIST=$(VMOD_VTC) $(VMOD_VTI)
23CLEANFILES=$(BUILT_TESTS)
24
9distclean-local: 25distclean-local:
10 rm -fr tbf 26 rm -fr tbf
11 27
12check: 28check: $(BUILT_TESTS)
13 cd $(abs_srcdir); \
14 for t in $(VMOD_TESTS); do \ 29 for t in $(VMOD_TESTS); do \
30 n=$${t%%.vti}; \
31 if [ $$n != $$t ]; then \
32 t=$(abs_builddir)/$${n}.vtc;\
33 else \
34 t=$(abs_srcdir)/$$t;\
35 fi; \
15 $(VARNISHSRC)/bin/varnishtest/varnishtest \ 36 $(VARNISHSRC)/bin/varnishtest/varnishtest \
16 -Dvarnishd=$(VARNISHSRC)/bin/varnishd/varnishd \ 37 -Dvarnishd=$(VARNISHSRC)/bin/varnishd/varnishd \
17 -Dvmod_topsrc=$(abs_top_srcdir) \ 38 -Dvmod_topsrc=$(abs_top_srcdir) \

Return to:

Send suggestions and report system problems to the System administrator.