aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 26 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4790115..0f90aa7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,16 @@
+VMOD_VTC = \
+ test01.vtc\
+ test03.vtc\
+ time00.vtc
+
+VMOD_VTI = \
+ test00.vti\
+ test02.vti
+
+BUILT_TESTS = $(VMOD_VTI:.vti=.vtc)
+
VMOD_TESTS = \
- test00.vtc\
+ test00.vti\
test01.vtc\
- test02.vtc\
+ test02.vti\
test03.vtc\
@@ -7,3 +18,8 @@ VMOD_TESTS = \
-EXTRA_DIST=$(VMOD_TESTS)
+.vti.vtc:
+ sed 's/^#VARNISH$(VARNISHVERSION)#//' $< > $@
+
+EXTRA_DIST=$(VMOD_VTC) $(VMOD_VTI)
+CLEANFILES=$(BUILT_TESTS)
+
distclean-local:
@@ -11,5 +27,10 @@ distclean-local:
-check:
- cd $(abs_srcdir); \
+check: $(BUILT_TESTS)
for t in $(VMOD_TESTS); do \
+ n=$${t%%.vti}; \
+ if [ $$n != $$t ]; then \
+ t=$(abs_builddir)/$${n}.vtc;\
+ else \
+ t=$(abs_srcdir)/$$t;\
+ fi; \
$(VARNISHSRC)/bin/varnishtest/varnishtest \

Return to:

Send suggestions and report system problems to the System administrator.