aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2014-11-01 14:10:23 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2014-11-01 14:10:23 +0200
commitdacdfd20c9e59e088bfb23c2852b566acc6ad06f (patch)
tree9c8acf2e253afd9593d5f6fccd560f7173485d48 /tests/Makefile.am
parent4d452a770122daf33fdbe0a549e2804b6f2db086 (diff)
downloadvmod-tbf-dacdfd20c9e59e088bfb23c2852b566acc6ad06f.tar.gz
vmod-tbf-dacdfd20c9e59e088bfb23c2852b566acc6ad06f.tar.bz2
Support for VCL 4.0
* NEWS: Update. * configure.ac: Version 1.0.90 Detect Varnish version, set up the C defines and automake conditionals to indicate it. * src/.gitignore: Update. * src/Makefile.am: Don't distribute vcc_if.c and vcc_if.h, build them for the current Varnish version. * src/tbf.h: New file. * src/getla.c: Include tbf.h, rewrite to compile with both 3.0 and 4.0 * src/sleep.c: Likewise. * src/tbf.c: Likewise. * src/time.c: Likewise. * src/vmod_tbf.vcc: Rewrite using v4.0 format. * tests/.gitignore: New file. * tests/Makefile.am: Build test00.vtc and test02.vtc * tests/test00.vtc: Rename to tests/test00.vti, add conditional compilation directives. * tests/test02.vtc: Rename to tests/test02.vti, add conditional compilation directives.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 26 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4790115..0f90aa7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,17 +1,38 @@
+VMOD_VTC = \
+ test01.vtc\
+ test03.vtc\
+ time00.vtc
+
+VMOD_VTI = \
+ test00.vti\
+ test02.vti
+
+BUILT_TESTS = $(VMOD_VTI:.vti=.vtc)
+
VMOD_TESTS = \
- test00.vtc\
+ test00.vti\
test01.vtc\
- test02.vtc\
+ test02.vti\
test03.vtc\
time00.vtc
-EXTRA_DIST=$(VMOD_TESTS)
+.vti.vtc:
+ sed 's/^#VARNISH$(VARNISHVERSION)#//' $< > $@
+
+EXTRA_DIST=$(VMOD_VTC) $(VMOD_VTI)
+CLEANFILES=$(BUILT_TESTS)
+
distclean-local:
rm -fr tbf
-check:
- cd $(abs_srcdir); \
+check: $(BUILT_TESTS)
for t in $(VMOD_TESTS); do \
+ n=$${t%%.vti}; \
+ if [ $$n != $$t ]; then \
+ t=$(abs_builddir)/$${n}.vtc;\
+ else \
+ t=$(abs_srcdir)/$$t;\
+ fi; \
$(VARNISHSRC)/bin/varnishtest/varnishtest \
-Dvarnishd=$(VARNISHSRC)/bin/varnishd/varnishd \
-Dvmod_topsrc=$(abs_top_srcdir) \

Return to:

Send suggestions and report system problems to the System administrator.