aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-19 00:33:41 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-19 00:33:41 +0300
commitaa4306ad7e683d74c214be2278c697b58a0936d6 (patch)
tree14ade48cb5127361ee5845389a70cdbc1cf0f3dd /configure.ac
parent0d499a8da2310909e04099db558b7823f4df3837 (diff)
downloadvmod-tbf-aa4306ad7e683d74c214be2278c697b58a0936d6.tar.gz
vmod-tbf-aa4306ad7e683d74c214be2278c697b58a0936d6.tar.bz2
Get rid of the --with-vmod-dir option.
* Makefile.am: Add default options for distcheck. * configure.ac: Remove --with-vmod-dir, default to the standard Varnish module location, Provide the --without-vmoddir option for use in distcheck. * README: Update.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 12 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 4ca4e6f..0bb6d3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,20 +78,19 @@ AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
)
# vmod installation dir
-AC_ARG_VAR([VMODDIR],
- [vmod installation directory @<:@LIBDIR/varnish/vmods@:>@])
-AC_ARG_WITH([vmod-dir],
- AC_HELP_STRING([--with-vmod-dir@<:@=DIR@:>@],
- [install modules to DIR; if used without arguments, install them to the varnish module directory]),
+AC_ARG_VAR([VMODDIR], [vmod installation directory])
+AC_ARG_WITH([vmoddir],
+ AC_HELP_STRING([--with-vmoddir=DIR],
+ [install modules to DIR]),
[case "$withval" in
- yes)
- VMODDIR=`pkg-config --variable=vmoddir varnishapi`
- if test -z "$VMODDIR"; then
- AC_MSG_FAILURE([cannot determine vmod installation directory])
- fi;;
- /*) VMODDIR=$withval;;
- *) AC_MSG_ERROR([argument to --with-vmod-dir must be absolute pathname])
- esac])
+ /*) VMODDIR=$withval;;
+ no) unset VMODDIR;;
+ *) AC_MSG_ERROR([argument to --with-vmoddir must be absolute pathname])
+ esac],[VMODDIR=`pkg-config --variable=vmoddir varnishapi`
+ if test -z "$VMODDIR"; then
+ AC_MSG_FAILURE([cannot determine vmod installation directory])
+ fi])
+
if test -z "$VMODDIR"; then
VMODDIR='$(libdir)/varnish/mods'

Return to:

Send suggestions and report system problems to the System administrator.