summaryrefslogtreecommitdiffabout
Side-by-side diff
Diffstat (more/less context) (ignore whitespace changes)
-rw-r--r--NEWS14
-rw-r--r--README27
2 files changed, 25 insertions, 16 deletions
diff --git a/NEWS b/NEWS
index a17e5e6..1301b03 100644
--- a/NEWS
+++ b/NEWS
@@ -1,18 +1,18 @@
-vmod-sql -- history of user-visible changes. 2016-01-24
-Copyright (C) 2013-2016 Sergey Poznyakoff
+vmod-sql -- history of user-visible changes. 2017-08-06
+Copyright (C) 2013-2017 Sergey Poznyakoff
See the end of file for copying conditions.
Please send vmod-sql bug reports to <gray@gnu.org>
-Version 1.0.90-4.1.0 (git)
+Version 1.0.91 (git)
* Support for Varnish 4.1
-* Versioning changes
+* The --with-varnish-source option has been withdrawn
-Starting with this release, the version number includes version
-of Varnish API the release was designed for.
+The configure script relies on pkg-config to determine the location of
+Varnish header files and libraries.
Version 1.0, 2013-10-19
@@ -22,7 +22,7 @@ Initial release
=========================================================================
Copyright information:
-Copyright (C) 2016 Sergey Poznyakoff
+Copyright (C) 2017 Sergey Poznyakoff
Permission is granted to anyone to make or distribute verbatim copies
of this document as received, in any medium, provided that the
diff --git a/README b/README
index 276eb74..3f96b03 100644
--- a/README
+++ b/README
@@ -17,26 +17,35 @@ MySQL and PostgreSQL databases from VCL scripts.
* Installation
-In order to compile the package you need to have Varnish source tree.
-At least Varnish 3.0.1 is required. Supposing that the varnish source tree
-is available under /usr/src/varnish-3.0.1, run:
+In order to compile the package you need to have the varnishd and
+varnishapi packages installed.
- ./configure --with-varnish-source=/usr/src/varnish-3.0.1
+Supposing that condition is met, run:
-The `--with-varnish-source' option is mandatory: it tells configure
-where Varnish sources reside.
+ ./configure
+
+It should be able to automatically find the necessary components. In case
+it doesn't, tweak the configuration variables as necessary. The most
+important one is PKG_CONFIG_PATH, which contains a path (in the UNIX sense)
+where the .pc files are located. It should contain a directory where the
+'varnishapi.pc' file lives. Example usage:
+
+ ./configure PKG_CONFIG_PATH=/usr/local/varnish/lib/pkgconfig:$PKG_CONFIG_PATH
+
+Please read the file INSTALL for a detailed discussion of available variables
+and command line options.
Once configured, do
-
+
make
This will build the module. After this step you can optionally run
'make test' to test the package.
Finally, run the following command as root:
-
- make install
+ make install
+
* Documentation
The manual page vmod-sql(3) will be available after successful install.

Return to:

Send suggestions and report system problems to the System administrator.