aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..a41c1ed
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,52 @@
+# This file is part of vmod-geoip
+# Copyright (C) 2017 Sergey Poznyakoff
+#
+# Vmod-geoip is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Vmod-geoip is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with vmod-geoip. If not, see <http://www.gnu.org/licenses/>.
+
+AM_CPPFLAGS =\
+ -I$(VARNISHSRC)/include\
+ -I$(VARNISHSRC)/bin/varnishd\
+ -I$(VARNISHSRC)\
+ @MMDB_CFLAGS@
+
+vmoddir = $(VMODDIR)
+vmod_LTLIBRARIES = libvmod_geoip.la
+
+libvmod_geoip_la_LDFLAGS = -module -export-dynamic -avoid-version
+libvmod_geoip_la_LIBADD=@MMDB_LIBS@
+
+libvmod_geoip_la_SOURCES = \
+ vmod_geoip.c
+
+nodist_libvmod_geoip_la_SOURCES = vcc_if.c vcc_if.h
+
+vmod_geoip.lo: vcc_if.h
+
+CLEANFILES = vcc_if.c vcc_if.h *.rst
+
+vmodtool = $(VARNISHSRC)/lib/libvcc/vmodtool.py
+vmodtoolargs = --strict
+vccfile = $(top_srcdir)/src/vmod_geoip.vcc
+
+vcc_if.c vcc_if.h: $(vmodtool) $(vccfile)
+ $(AM_V_GEN)$(PYTHON) $(vmodtool) $(vmodtoolargs) $(vccfile)
+
+EXTRA_DIST = \
+ vmod_geoip.vcc
+
+dist_man_MANS=vmod_geoip.3
+
+vmod_geoip.3: vmod_geoip.man.rst
+ @$(abs_top_srcdir)/build-aux/missing rst2man.py vmod_geoip.man.rst > vmod_geoip.3
+

Return to:

Send suggestions and report system problems to the System administrator.