aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-08-01 11:22:27 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2017-08-01 11:36:20 +0300
commitd7399e572e334fb036c7f6b59400f5075147054c (patch)
tree868c700aa625ab8d413a4191ec3c6cc61b72e5ad /src/Makefile.am
downloadvmod-dict-d7399e572e334fb036c7f6b59400f5075147054c.tar.gz
vmod-dict-d7399e572e334fb036c7f6b59400f5075147054c.tar.bz2
Initial commit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bff41f5
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,56 @@
+# This file is part of vmod_dict.
+# Copyright (C) 2017 Sergey Poznyakoff
+#
+# Vmod_dict is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Vmod_dict is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with vmod_dict. If not, see <http://www.gnu.org/licenses/>.
+
+AM_CPPFLAGS=\
+ $(VARNISHAPI_CFLAGS)\
+ -DLOCALSTATEDIR=\"$(localstatedir)\"
+
+vmoddir = $(VMODDIR)
+vmod_LTLIBRARIES = libvmod_dict.la
+
+libvmod_dict_la_LDFLAGS=-module -export-dynamic -avoid-version
+libvmod_dict_la_LIBADD=
+
+libvmod_dict_la_SOURCES = \
+ vmod_dict.c
+
+nodist_libvmod_dict_la_SOURCES = \
+ vcc_if.c vcc_if.h
+
+vmod_dict.lo: vcc_if.h
+
+CLEANFILES = vcc_if.c vcc_if.h *.rst
+
+vmodtoolargs = --strict
+vccfile = $(top_srcdir)/src/vmod_dict.vcc
+
+vcc_if.c vcc_if.h: $(vccfile)
+ $(AM_V_GEN)$(PYTHON) $(VARNISHAPI_VMODTOOL) $(vmodtoolargs) $(vccfile)
+
+EXTRA_DIST = \
+ vmod_dict.vcc\
+ vmod_dict.man.rst\
+ vmod_dict.rst
+
+dist_man_MANS=vmod_dict.3
+
+DISTCLEANFILES=vmod_dict.3
+
+vmod_dict.3: vmod_dict.man.rst
+ @$(abs_top_srcdir)/build-aux/missing rst2man.py \
+ vmod_dict.man.rst > vmod_dict.3
+
+

Return to:

Send suggestions and report system problems to the System administrator.