aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-08-01 11:22:27 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2017-08-01 11:36:20 +0300
commitd7399e572e334fb036c7f6b59400f5075147054c (patch)
tree868c700aa625ab8d413a4191ec3c6cc61b72e5ad /configure.ac
downloadvmod-dict-d7399e572e334fb036c7f6b59400f5075147054c.tar.gz
vmod-dict-d7399e572e334fb036c7f6b59400f5075147054c.tar.bz2
Initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 58 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f26c1c2
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,58 @@
+# This file is part of vmod_dict.
+# Copyright (C) 2017 Sergey Poznyakoff
+#
+# Vmod_dict is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Vmod_dict is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with vmod_dict. If not, see <http://www.gnu.org/licenses/>.
+
+AC_PREREQ(2.69)
+AC_INIT([vmod-dict], [0.1], [gray@gnu.org])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR(src/vmod_dict.vcc)
+AM_CONFIG_HEADER(config.h)
+
+AC_CANONICAL_SYSTEM
+AC_LANG(C)
+
+AM_INIT_AUTOMAKE([1.14 gnu tar-ustar silent-rules])
+AM_SILENT_RULES([yes])
+
+AC_GNU_SOURCE
+AC_PROG_CC
+AC_PROG_CC_STDC
+if test "x$ac_cv_prog_cc_c99" = xno; then
+ AC_MSG_ERROR([could not find a C99 compatible compiler])
+fi
+AC_PROG_CPP
+
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+AC_PROG_MAKE_SET
+
+# Checks for header files.
+AC_HEADER_STDC
+
+# Check for functions
+
+AM_VARNISHAPI([4.1])
+
+AC_CONFIG_TESTDIR(tests)
+AC_CONFIG_FILES([tests/Makefile tests/atlocal])
+AM_MISSING_PROG([AUTOM4TE], [autom4te])
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+AC_OUTPUT
+

Return to:

Send suggestions and report system problems to the System administrator.