summaryrefslogtreecommitdiffabout
authorSergey Poznyakoff <gray@gnu.org>2020-03-27 09:36:30 (GMT)
committer Sergey Poznyakoff <gray@gnu.org>2020-03-27 09:36:30 (GMT)
commit4564b6c9776eecfece2eb097ebe5aebfd79c9cb8 (patch) (side-by-side diff)
tree12aaa33b46c9f8c85d8b5897079f21ea15ede0fc
parent87ff2f5ebb147d6800b838d8e9dd6063305ddd47 (diff)
downloadvmod-dict-4564b6c9776eecfece2eb097ebe5aebfd79c9cb8.tar.gz
vmod-dict-4564b6c9776eecfece2eb097ebe5aebfd79c9cb8.tar.bz2
Drop support for Varnish versions prior to 6.0
Diffstat (more/less context) (ignore whitespace changes)
-rw-r--r--NEWS7
-rw-r--r--README5
m---------acvmod0
-rw-r--r--configure.ac4
-rw-r--r--src/vmod_dict.c13
5 files changed, 14 insertions, 15 deletions
diff --git a/NEWS b/NEWS
index a28b8f9..bc30866 100644
--- a/NEWS
+++ b/NEWS
@@ -1,2 +1,2 @@
-vmod_dict -- history of user-visible changes. 2020-03-03
+vmod_dict -- history of user-visible changes. 2020-03-27
See the end of file for copying conditions.
@@ -5,2 +5,7 @@ Please send vmod_dict bug reports to <gray@gnu.org>
+Version 1.3.90 (git)
+
+* Drop support for Varnish versions prior to 6.0.0
+
+
Version 1.3, 2020-03-03
diff --git a/README b/README
index 7c4a5c5..3affbfc 100644
--- a/README
+++ b/README
@@ -39,2 +39,4 @@ as follows:
+The module has been tested with Varnish versions 6.0.2 -- 6.3.2.
+
* Installation
@@ -42,4 +44,3 @@ as follows:
In order to compile the package you need to have installed
-varnishd and varnishapi package. The module has been tested with
-Varnish versions 4.1, 5.1, and 6.0.2.
+varnishd and varnishapi package.
diff --git a/acvmod b/acvmod
-Subproject 5b214e3d72f9e261a37cf31deb41e7f8a61a181
+Subproject 99b8dd21c7d1a91021b0a63c0d846ac35c4b009
diff --git a/configure.ac b/configure.ac
index c37cc81..0dc3f0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,3 +17,3 @@
AC_PREREQ(2.69)
-AC_INIT([vmod-dict], [1.3], [gray@gnu.org])
+AC_INIT([vmod-dict], [1.3.90], [gray@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
@@ -47,3 +47,3 @@ AC_HEADER_STDC
-AM_VARNISHAPI([4.1],[6.3.2])
+AM_VARNISHAPI([6.0.0],[6.3.2])
AC_DEFINE_UNQUOTED([VARNISHAPI_MAJOR],[$VARNISHAPI_MAJOR],
diff --git a/src/vmod_dict.c b/src/vmod_dict.c
index 8c1e230..3163657 100644
--- a/src/vmod_dict.c
+++ b/src/vmod_dict.c
@@ -24,12 +24,5 @@
#include <syslog.h>
-#if VARNISHAPI_MAJOR > 5
-# include <cache/cache.h>
-# include <vcl.h>
-# include <vcc_if.h>
-#else
-# include <vcl.h>
-# include <vrt.h>
-# include <vcc_if.h>
-# include <cache/cache.h>
-#endif
+#include <cache/cache.h>
+#include <vcl.h>
+#include <vcc_if.h>

Return to:

Send suggestions and report system problems to the System administrator.