aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6cda3aa..2f23477 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,8 +1,8 @@
# This file is part of vmod-dbrw
-# Copyright (C) 2013-2017 Sergey Poznyakoff
+# Copyright (C) 2013-2019 Sergey Poznyakoff
#
# Vmod-dbrw is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
@@ -11,20 +11,26 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with vmod-dbrw. If not, see <http://www.gnu.org/licenses/>.
-AM_CPPFLAGS=$(VARNISHAPI_CFLAGS) -I$(srcdir) -I$(builddir)
+AM_CPPFLAGS=\
+ $(VARNISHAPI_CFLAGS)\
+ -I$(srcdir)\
+ -I$(builddir)\
+ -I$(top_srcdir)/wordsplit
noinst_LTLIBRARIES = libsql.la
libsql_la_SOURCES = \
be.c\
dbrw.h\
- sql.c\
+ sql.c
+nodist_libsql_la_SOURCES = \
wordsplit.h\
wordsplit.c
+VPATH += $(top_srcdir)/wordsplit
if USE_MYSQL
libsql_la_SOURCES += mysql.c
endif
if USE_PGSQL

Return to:

Send suggestions and report system problems to the System administrator.