aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2016-01-24 00:34:07 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2016-01-24 00:37:26 +0200
commit226acfe9d91317d1bd516e77d109cdcccb8ee8a7 (patch)
treea9f94c5c08f2659bc9ed3e18cf4a9b8756943019 /src/Makefile.am
parent88662efe6a07c531878e1c56ca68e22a906e83ba (diff)
downloadvmod-dbrw-226acfe9d91317d1bd516e77d109cdcccb8ee8a7.tar.gz
vmod-dbrw-226acfe9d91317d1bd516e77d109cdcccb8ee8a7.tar.bz2
Varnish 4.1
* .gitmodules: New file. * acvmod: New submodule. * bootstrap: Update. * Makefile.am (ACLOCAL_AMFLAGS): Add acvmod * configure.ac: Use AM_VARNISHAPI instead of inlining the related code. Enable silent rules. Set version number 2.0.90-4.1.0 * src/Makefile.am: Enable silent rules. * tests/Makefile.am: Likewise. * tests/atlocal.in (at_vcl_backend): Remove conditional. * src/vmod_dbrw.c: Use event function. * src/vmod_dbrw.vcc: Likewise. * NEWS: Document changes.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 5 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1f8bc81..00110d9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of vmod-dbrw
-# Copyright (C) 2013-2014 Sergey Poznyakoff
+# Copyright (C) 2013-2014, 2016 Sergey Poznyakoff
#
# Vmod-dbrw is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -50,24 +50,12 @@ vmod_dbrw.lo: vcc_if.h
CLEANFILES = vcc_if.c vcc_if.h *.rst
-if VARNISH4
- vmodtool = $(VARNISHSRC)/lib/libvcc/vmodtool.py
- vmodtoolargs = --strict
- vccfile = $(top_srcdir)/src/vmod_dbrw.vcc
-else
- vmodtool = $(VARNISHSRC)/lib/libvmod_std/vmod.py
- vmodtoolargs =
- vccfile = vmod_dbrw.vcc3
-
-vmod_dbrw.vcc3: $(top_srcdir)/src/vmod_dbrw.vcc
- CLEANFILES += vmod_dbrw.vcc3
-endif
-
-.vcc.vcc3:
- sed -n '/^\$$/{s///;s/\(Module *[^ ][^ ]*\).*/\1/;p}' $< > $@
+vmodtool = $(VARNISHSRC)/lib/libvcc/vmodtool.py
+vmodtoolargs = --strict
+vccfile = $(top_srcdir)/src/vmod_dbrw.vcc
vcc_if.c vcc_if.h: $(vmodtool) $(vccfile)
- @PYTHON@ $(vmodtool) $(vmodtoolargs) $(vccfile)
+ $(AM_V_GEN)$(PYTHON) $(vmodtool) $(vmodtoolargs) $(vccfile)
EXTRA_DIST = \
vmod_dbrw.vcc

Return to:

Send suggestions and report system problems to the System administrator.