aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-19 00:29:59 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-19 00:29:59 +0300
commitb9581bc92dee8ad1c479deb01fefc451885cc548 (patch)
treef6411e9caed4db730c4ad30ff39237506ce1b3db /configure.ac
parent0b7dd9ce3d77e4d99de006f3a3a86134e2d7f809 (diff)
downloadvmod-dbrw-b9581bc92dee8ad1c479deb01fefc451885cc548.tar.gz
vmod-dbrw-b9581bc92dee8ad1c479deb01fefc451885cc548.tar.bz2
Get rid of the --with-vmod-dir option.
* Makefile.am: Add default options for distcheck. * configure.ac: Remove --with-vmod-dir, default to the standard Varnish module location, Provide the --without-vmoddir option for use in distcheck.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 12 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 8405cfc..715728b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,20 +75,19 @@ AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
)
# vmod installation dir
-AC_ARG_VAR([VMODDIR],
- [vmod installation directory @<:@LIBDIR/varnish/vmods@:>@])
-AC_ARG_WITH([vmod-dir],
- AC_HELP_STRING([--with-vmod-dir@<:@=DIR@:>@],
- [install modules to DIR; if used without arguments, install them to the varnish module directory]),
+AC_ARG_VAR([VMODDIR], [vmod installation directory])
+AC_ARG_WITH([vmoddir],
+ AC_HELP_STRING([--with-vmoddir=DIR],
+ [install modules to DIR]),
[case "$withval" in
- yes)
- VMODDIR=`pkg-config --variable=vmoddir varnishapi`
- if test -z "$VMODDIR"; then
- AC_MSG_FAILURE([cannot determine vmod installation directory])
- fi;;
- /*) VMODDIR=$withval;;
- *) AC_MSG_ERROR([argument to --with-vmod-dir must be absolute pathname])
- esac])
+ /*) VMODDIR=$withval;;
+ no) unset VMODDIR;;
+ *) AC_MSG_ERROR([argument to --with-vmoddir must be absolute pathname])
+ esac],[VMODDIR=`pkg-config --variable=vmoddir varnishapi`
+ if test -z "$VMODDIR"; then
+ AC_MSG_FAILURE([cannot determine vmod installation directory])
+ fi])
+
if test -z "$VMODDIR"; then
VMODDIR='$(libdir)/varnish/mods'

Return to:

Send suggestions and report system problems to the System administrator.