aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c9daf9a
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,41 @@
+# This file is part of vmod-binlog
+# Copyright (C) 2013 Sergey Poznyakoff
+#
+# Vmod-binlog is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Vmod-binlog is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with vmod-binlog. If not, see <http://www.gnu.org/licenses/>.
+
+AM_CPPFLAGS = -I$(VARNISHSRC)/include -I$(VARNISHSRC)
+
+bin_PROGRAMS = binlogcat
+binlogcat_SOURCES = binlogcat.c
+
+vmoddir = $(VMODDIR)
+vmod_LTLIBRARIES = libvmod_binlog.la
+
+libvmod_binlog_la_LDFLAGS = -module -export-dynamic -avoid-version
+libvmod_binlog_la_LIBADD=
+
+libvmod_binlog_la_SOURCES = \
+ binlog.c\
+ vmod-binlog.h\
+ vcc_if.c vcc_if.h
+
+BUILT_SOURCES = vcc_if.c vcc_if.h
+
+vcc_if.c vcc_if.h: $(VARNISHSRC)/lib/libvmod_std/vmod.py $(top_srcdir)/src/vmod.vcc
+ @PYTHON@ $(VARNISHSRC)/lib/libvmod_std/vmod.py $(top_srcdir)/src/vmod.vcc
+
+EXTRA_DIST = vmod.vcc
+
+CLEANFILES = $(builddir)/vcc_if.c $(builddir)/vcc_if.h
+

Return to:

Send suggestions and report system problems to the System administrator.