aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5c74cb7..c4c9872 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ AM_CONFIG_HEADER(config.h)
AC_CANONICAL_SYSTEM
AC_LANG(C)
-AM_INIT_AUTOMAKE([gnu tar-ustar])
+AM_INIT_AUTOMAKE([gnu tar-ustar subdir-objects])
AC_GNU_SOURCE
AC_PROG_CC
@@ -38,6 +38,12 @@ AC_PROG_INSTALL
AC_PROG_LIBTOOL
AC_PROG_MAKE_SET
+LT_PREREQ(2.2.5a)
+LT_CONFIG_LTDL_DIR([libltdl])
+LT_INIT([dlopen])
+LTDL_INIT([recursive])
+AC_CONFIG_FILES([libltdl/Makefile])
+
# Check for pkg-config
PKG_PROG_PKG_CONFIG
@@ -97,6 +103,8 @@ if test -z "$VMODDIR"; then
VMODDIR='$(libdir)/varnish/mods'
fi
+AC_SUBST(BINLOGSEL_MODDIR,'$(libdir)/$(PACKAGE)')
+
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal])

Return to:

Send suggestions and report system problems to the System administrator.