aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-14 15:28:51 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-14 17:54:41 +0300
commitf035194d7d1b6cc0846ad7a5d86e0d6fa9463c67 (patch)
tree494d180cee9a078727c8d4965caa65cb2052f33d /src/Makefile.am
parent58f7dbc0658b3d73816a1bc91b75c2bdac733510 (diff)
downloadvmod-binlog-f035194d7d1b6cc0846ad7a5d86e0d6fa9463c67.tar.gz
vmod-binlog-f035194d7d1b6cc0846ad7a5d86e0d6fa9463c67.tar.bz2
New utility binlogsel
* configure.ac: Check for yacc. * src/.gitignore: Update. * src/Makefile.am (libbinlog_a_SOURCES): Add new files. Build binlogsel. * src/binlogcat.c: Use xmalloc. * src/binlogsel.c: New file. * src/parse-datetime.h: New file. * src/parse-datetime.y: New file. * src/xalloc.c: New file. * src/xalloc.h: New file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4e31e89..565444a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,13 +17,16 @@
17AM_CPPFLAGS = -I$(VARNISHSRC)/include -I$(VARNISHSRC) 17AM_CPPFLAGS = -I$(VARNISHSRC)/include -I$(VARNISHSRC)
18 18
19noinst_LIBRARIES = libbinlog.a 19noinst_LIBRARIES = libbinlog.a
20libbinlog_a_SOURCES = pack.c err.c 20libbinlog_a_SOURCES = pack.c err.c parse-datetime.y xalloc.c
21libbinlog_a_CFLAGS = $(AM_CFLAGS) 21libbinlog_a_CFLAGS = $(AM_CFLAGS)
22 22
23bin_PROGRAMS = binlogcat 23bin_PROGRAMS = binlogcat binlogsel
24binlogcat_SOURCES = binlogcat.c 24binlogcat_SOURCES = binlogcat.c
25binlogcat_LDADD = ./libbinlog.a 25binlogcat_LDADD = ./libbinlog.a
26 26
27binlogsel_SOURCES = binlogsel.c
28binlogsel_LDADD = ./libbinlog.a
29
27vmoddir = $(VMODDIR) 30vmoddir = $(VMODDIR)
28vmod_LTLIBRARIES = libvmod_binlog.la 31vmod_LTLIBRARIES = libvmod_binlog.la
29 32
@@ -36,7 +39,7 @@ libvmod_binlog_la_SOURCES = \
36 vmod-binlog.h\ 39 vmod-binlog.h\
37 vcc_if.c vcc_if.h 40 vcc_if.c vcc_if.h
38 41
39noinst_HEADERS = pack.h err.h 42noinst_HEADERS = pack.h err.h parse-datetime.h xalloc.h
40 43
41BUILT_SOURCES = vcc_if.c vcc_if.h 44BUILT_SOURCES = vcc_if.c vcc_if.h
42 45

Return to:

Send suggestions and report system problems to the System administrator.