aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-17 22:27:16 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-17 22:27:16 +0300
commit803128db75e3efea8cd7be29732a7b4315205d13 (patch)
tree713699a3724f905ca3dd740c386c9ffdb75e94a7 /src/Makefile.am
parentaad0ead6ae1bb56953642eac584d9a5f1dc6d72e (diff)
downloadvmod-binlog-803128db75e3efea8cd7be29732a7b4315205d13.tar.gz
vmod-binlog-803128db75e3efea8cd7be29732a7b4315205d13.tar.bz2
binlogsel: add loadable module support
* Makefile.am (SUBDIRS): Add libltdl * configure.ac: Configure ltdl * src/Makefile.am (binlogsel_LDADD): Add LIBLTDL. (binlogsel_CPPFLAGS): New variable. * src/binlogcat.c (catlog): Bugfix. * src/binlogsel.c: Allow for multiple intervals. Support loadable modules. * doc/binlogcat.1: Update. * doc/binlogsel.1: Update. * doc/vmod-binlog.3: Update.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 565444a..a20f9cb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,7 +25,9 @@ binlogcat_SOURCES = binlogcat.c
binlogcat_LDADD = ./libbinlog.a
binlogsel_SOURCES = binlogsel.c
-binlogsel_LDADD = ./libbinlog.a
+binlogsel_LDADD = ./libbinlog.a @LIBLTDL@
+binlogsel_CPPFLAGS =\
+ -DBINLOGSEL_MODDIR=\"$(BINLOGSEL_MODDIR)\"
vmoddir = $(VMODDIR)
vmod_LTLIBRARIES = libvmod_binlog.la

Return to:

Send suggestions and report system problems to the System administrator.