aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-13 12:44:12 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-13 12:48:04 +0300
commit23f262e8c6181465347c3bb47644f9d86fcb7432 (patch)
treecdf5ac3a861395ade00b71e7b8cdd641db67032c /src/Makefile.am
parent510fc646f13b843d046323e3477edb6c1bc2258d (diff)
downloadvmod-binlog-23f262e8c6181465347c3bb47644f9d86fcb7432.tar.gz
vmod-binlog-23f262e8c6181465347c3bb47644f9d86fcb7432.tar.bz2
* src/Makefile.am: New convenience library libbinlog.a
* src/binlogcat.c: Use functions from libbinlog.a * src/err.h: New file. * src/err.c: New file. * tests/.gitignore: Add binpack.c * tests/Makefile.am: Build binpack.c * tests/binpack.c: New file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9ce519f..4e31e89 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,5 +18,9 @@ AM_CPPFLAGS = -I$(VARNISHSRC)/include -I$(VARNISHSRC)
+noinst_LIBRARIES = libbinlog.a
+libbinlog_a_SOURCES = pack.c err.c
+libbinlog_a_CFLAGS = $(AM_CFLAGS)
+
bin_PROGRAMS = binlogcat
-binlogcat_SOURCES = binlogcat.c pack.c
-binlogcat_CFLAGS = $(AM_CFLAGS)
+binlogcat_SOURCES = binlogcat.c
+binlogcat_LDADD = ./libbinlog.a
@@ -34,3 +38,3 @@ libvmod_binlog_la_SOURCES = \
-noinst_HEADERS = pack.h
+noinst_HEADERS = pack.h err.h

Return to:

Send suggestions and report system problems to the System administrator.