aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-11 00:12:43 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-11 12:22:57 +0300
commitdf83b714395d41b096f7ad8cc3a090c9341f7598 (patch)
tree1c3bcc412e633d3fc678e2cc083ea947e5dcd8e8 /configure.ac
downloadvmod-binlog-df83b714395d41b096f7ad8cc3a090c9341f7598.tar.gz
vmod-binlog-df83b714395d41b096f7ad8cc3a090c9341f7598.tar.bz2
Initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac106
1 files changed, 106 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..2924eae
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,106 @@
+# This file is part of vmod-binlog
+# Copyright (C) 2013 Sergey Poznyakoff
+#
+# Vmod-binlog is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Vmod-binlog is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with vmod-sql. If not, see <http://www.gnu.org/licenses/>.
+AC_PREREQ(2.69)
+AC_INIT([vmod-binlog], 1.0, [gray@gnu.org])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR(src/binlog.c)
+AM_CONFIG_HEADER(config.h)
+
+AC_CANONICAL_SYSTEM
+AC_LANG(C)
+
+AM_INIT_AUTOMAKE([gnu tar-ustar])
+
+AC_GNU_SOURCE
+AC_PROG_CC
+AC_PROG_CC_STDC
+if test "x$ac_cv_prog_cc_c99" = xno; then
+ AC_MSG_ERROR([could not find a C99 compatible compiler])
+fi
+AC_PROG_CPP
+
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+AC_PROG_MAKE_SET
+
+# Check for pkg-config
+PKG_PROG_PKG_CONFIG
+
+AC_SYS_LARGEFILE
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([sys/stdlib.h])
+
+# Check for python
+AC_CHECK_PROGS(PYTHON, [python], [
+ AC_MSG_ERROR([python is not found.])])
+
+# Varnish source tree
+AC_ARG_VAR([VARNISHSRC], [path to Varnish source tree])
+AC_ARG_WITH([varnish-source],
+ AC_HELP_STRING([--with-varnish-source=DIR],
+ [Varnish sources are located in DIR]),
+ [VARNISHSRC=$withval])
+
+if test -z "$VARNISHSRC"; then
+ AC_MSG_ERROR([no Varnish source tree specified])
+fi
+case "$VARNISHSRC" in
+/*) ;;
+*) AC_MSG_ERROR([varnish source path must be absolute pathname])
+esac
+
+VARNISHSRC=`cd $VARNISHSRC && pwd`
+AC_CHECK_FILE([$VARNISHSRC/include/varnishapi.h],
+ [],
+ [AC_MSG_FAILURE(["$VARNISHSRC" is not a Varnish source directory])])
+
+# Check that varnishtest is built in the varnish source directory
+AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
+ [],
+ [AC_MSG_FAILURE([cannot find "$VARNISHSRC/bin/varnishtest/varnishtest". Please build your varnish source directory])]
+)
+
+# vmod installation dir
+AC_ARG_VAR([VMODDIR],
+ [vmod installation directory @<:@LIBDIR/varnish/vmods@:>@])
+AC_ARG_WITH([vmod-dir],
+ AC_HELP_STRING([--with-vmod-dir@<:@=DIR@:>@],
+ [install modules to DIR; if used without arguments, install them to the varnish module directory]),
+ [case "$withval" in
+ yes)
+ VMODDIR=`pkg-config --variable=vmoddir varnishapi`
+ if test -z "$VMODDIR"; then
+ AC_MSG_FAILURE([cannot determine vmod installation directory])
+ fi;;
+ /*) VMODDIR=$withval;;
+ *) AC_MSG_ERROR([argument to --with-vmod-dir must be absolute pathname])
+ esac])
+
+if test -z "$VMODDIR"; then
+ VMODDIR='$(libdir)/varnish/mods'
+fi
+
+dnl FIXME: tests/Makefile
+dnl FIXME: doc/Makefile
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+AC_OUTPUT
+

Return to:

Send suggestions and report system problems to the System administrator.