aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-10-17 22:27:16 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-10-17 22:27:16 +0300
commit803128db75e3efea8cd7be29732a7b4315205d13 (patch)
tree713699a3724f905ca3dd740c386c9ffdb75e94a7 /configure.ac
parentaad0ead6ae1bb56953642eac584d9a5f1dc6d72e (diff)
downloadvmod-binlog-803128db75e3efea8cd7be29732a7b4315205d13.tar.gz
vmod-binlog-803128db75e3efea8cd7be29732a7b4315205d13.tar.bz2
binlogsel: add loadable module support
* Makefile.am (SUBDIRS): Add libltdl * configure.ac: Configure ltdl * src/Makefile.am (binlogsel_LDADD): Add LIBLTDL. (binlogsel_CPPFLAGS): New variable. * src/binlogcat.c (catlog): Bugfix. * src/binlogsel.c: Allow for multiple intervals. Support loadable modules. * doc/binlogcat.1: Update. * doc/binlogsel.1: Update. * doc/vmod-binlog.3: Update.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5c74cb7..c4c9872 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ AM_CONFIG_HEADER(config.h)
AC_CANONICAL_SYSTEM
AC_LANG(C)
-AM_INIT_AUTOMAKE([gnu tar-ustar])
+AM_INIT_AUTOMAKE([gnu tar-ustar subdir-objects])
AC_GNU_SOURCE
AC_PROG_CC
@@ -38,6 +38,12 @@ AC_PROG_INSTALL
AC_PROG_LIBTOOL
AC_PROG_MAKE_SET
+LT_PREREQ(2.2.5a)
+LT_CONFIG_LTDL_DIR([libltdl])
+LT_INIT([dlopen])
+LTDL_INIT([recursive])
+AC_CONFIG_FILES([libltdl/Makefile])
+
# Check for pkg-config
PKG_PROG_PKG_CONFIG
@@ -97,6 +103,8 @@ if test -z "$VMODDIR"; then
VMODDIR='$(libdir)/varnish/mods'
fi
+AC_SUBST(BINLOGSEL_MODDIR,'$(libdir)/$(PACKAGE)')
+
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal])

Return to:

Send suggestions and report system problems to the System administrator.