aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..4e4347b
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,15 @@
+VMOD_TESTS = \
+ test00.vtc\
+ test01.vtc\
+ test02.vtc
+
+EXTRA_DIST=$(VMOD_TESTS) htpasswd
+
+check:
+ cd $(abs_srcdir); \
+ for t in $(VMOD_TESTS); do \
+ $(VARNISHSRC)/bin/varnishtest/varnishtest \
+ -Dvarnishd=$(VARNISHSRC)/bin/varnishd/varnishd \
+ -Dvmod_topsrc=$(abs_top_srcdir) \
+ -Dvmod_topbuild=$(abs_top_builddir) $$t; \
+ done

Return to:

Send suggestions and report system problems to the System administrator.