aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-07-08 16:30:22 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2013-07-08 16:34:34 +0300
commit08a7915aaf08e9d2187fd3f26e0326673d4c8eb1 (patch)
tree7d9f02b59945ae7577e79c3cbfe5182b3a22e4b8 /src/Makefile.am
parent4e2b6995088963e287de5dcc507a5ab14a7134b1 (diff)
downloadvmod-basicauth-08a7915aaf08e9d2187fd3f26e0326673d4c8eb1.tar.gz
vmod-basicauth-08a7915aaf08e9d2187fd3f26e0326673d4c8eb1.tar.bz2
Implement SHA1 passwords.
* src/sha1.c: New file. * src/sha1.h: New file. * src/Makefile.am: Add new files. * src/vmod_basicauth.c (base64_decode): Fix bound checking. (sha1_match): New function. (match_tab): Add SHA1 method. * tests/test03.vtc: New test. * tests/Makefile.am: Add new file. * tests/htpasswd: Add SHA1 password. * README: Update. * src/vmod_basicauth.3: Update.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 92f15ca..e4fdb51 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,6 +11,8 @@ libvmod_basicauth_la_LIBADD=-lcrypt
libvmod_basicauth_la_SOURCES = \
basicauth.h\
md5.c\
+ sha1.c\
+ sha1.h\
vcc_if.c \
vcc_if.h \
vmod_basicauth.c

Return to:

Send suggestions and report system problems to the System administrator.