aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2014-11-01 13:51:58 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2014-11-01 14:01:54 +0200
commit43ad26ba4149be4700ea60ad0750454bc9420c4b (patch)
tree6e5777f849f5fd557fa2e5885d38cfc927510eea /configure.ac
parent94e89bc0207394e49295bdeade92d8a6322a8aa7 (diff)
downloadvmod-basicauth-43ad26ba4149be4700ea60ad0750454bc9420c4b.tar.gz
vmod-basicauth-43ad26ba4149be4700ea60ad0750454bc9420c4b.tar.bz2
Support for VCL 4.0
* NEWS: Update. * configure.ac: Version 1.2.90 Detect varnish version. * src/.gitignore: Update. * src/Makefile.am: Always build vcc_if.c and vcc_if.h, don't include them in the distribution. (.vcc.vcc3): New implicit rule for VCL 3.0 * src/vmod_basicauth.c: Include config.h. Define varnish datatypes depending on the value of VARNISHVERSION. (vmod_match): Change declaration. * src/vmod_basicauth.vcc: Rewrite.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5df1fde..83d52ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,7 @@
# You should have received a copy of the GNU General Public License
# along with vmod-basicauth. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.69)
-AC_INIT([vmod-basicauth], 1.2, [gray@gnu.org])
+AC_INIT([vmod-basicauth], 1.2.90, [gray@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SRCDIR(src/vmod_basicauth.vcc)
@@ -64,10 +64,17 @@ case "$VARNISHSRC" in
esac
VARNISHSRC=`cd $VARNISHSRC && pwd`
+VARNISHVERSION=
AC_CHECK_FILE([$VARNISHSRC/include/varnishapi.h],
- [],
- [AC_MSG_FAILURE(["$VARNISHSRC" is not a Varnish source directory])])
-
+ [VARNISHVERSION=3],
+ [AC_CHECK_FILE([$VARNISHSRC/include/vapi/vsm.h],
+ [VARNISHVERSION=4],
+ [AC_MSG_FAILURE(["$VARNISHSRC" is not a Varnish source directory])]) ])
+
+AC_DEFINE_UNQUOTED([VARNISHVERSION],$VARNISHVERSION,[Varnish major version number])
+AM_CONDITIONAL([VARNISH3],[test $VARNISHVERSION -eq 3])
+AM_CONDITIONAL([VARNISH4],[test $VARNISHVERSION -eq 4])
+
# Check that varnishtest is built in the varnish source directory
AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
[],

Return to:

Send suggestions and report system problems to the System administrator.