aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@nxc.no>2018-02-04 10:11:07 +0100
committerSergey Poznyakoff <gray@nxc.no>2018-02-04 12:52:11 +0100
commit7651936f80b1bc6f5b01477ee9e648843097d7b8 (patch)
treeec6232e179767283c557b6c1babf23bcb1bb455a /src/Makefile.am
parent82822c0a336018e33658aebb166819c960e92140 (diff)
downloadvarnish-mib-7651936f80b1bc6f5b01477ee9e648843097d7b8.tar.gz
varnish-mib-7651936f80b1bc6f5b01477ee9e648843097d7b8.tar.bz2
Rewrite hash table support.
* .gitignore: Update. * Makefile.am (EXTRA_DIST): Add perl modules from lib/VarnishMib * lib/VarnishMib/HashTable.pm: New file. * lib/VarnishMib/MIBTable.pm: New file. * src/Makefile.am (varnish_mib_la_SOURCES): Remove statdict. (.mib2c.c): Set PERL5LIB * src/betab.c (backend_dfn.vpt): Remove const qualifier. (backend_register): Store in vpt cloned points. (backend_clear): Destroy points in vpt. * src/statdict.c: Remove. * src/varnish_mib.mib2c: Use VarnishMib::MIBTable. Set mib2c variable $varnish_hash_table to an instance of VarnishMib::MIBTable. Use it to generate lookup table code section. (varnish_var_lookup, varnish_get_oid) (dict_clear, dict_install, dict_load): New functions. (handle_$i): Use direct addressing to obtain a vpt. Fix handling of ASN_TIMETICKS.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3ef9fa5..55cdb85 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,38 +18,39 @@ dlmoddir=@DLMODDIR@
dlmod_LTLIBRARIES = varnish-mib.la
varnish_mib_la_SOURCES = \
auth.c\
ban.c\
backend.h\
belex.l\
betab.c\
modconf.h\
modconf.c\
sha256.c\
sha256.h\
- statdict.c\
varnish_mib.c\
varnish_mib.h\
vcli.c\
vclient.h
BUILT_SOURCES = \
varnish_mib.c\
varnish_mib.h
varnish_mib.c varnish_mib.h: varnish_mib.mib2c VARNISH-MIB.txt
.mib2c.c:
- MIBDIRS=${top_srcdir}/src:${NET_SNMP_MIBDIRS} MIBS="VARNISH-MIB:${NET_SNMP_MIBS}" \
+ MIBDIRS=${top_srcdir}/src:${NET_SNMP_MIBDIRS}\
+ MIBS="VARNISH-MIB:${NET_SNMP_MIBS}" \
+ PERL5LIB=${top_srcdir}/lib \
mib2c -c $< -f $@ varnish
#NET_SNMP_INCLUDES = `$(NET_SNMP_CONFIG) --cflags`
#NET_SNMP_INCLUDES =
NET_SNMP_LIBS = `$(NET_SNMP_CONFIG) --libs`
NET_SNMP_EXLIBS = `$(NET_SNMP_CONFIG) --external-libs`
NET_SNMP_MIBDIRS = `net-snmp-config --mibdirs`
NET_SNMP_MIBS = `net-snmp-config --default-mibs`
AM_LDFLAGS = \
-module \
-export-dynamic\

Return to:

Send suggestions and report system problems to the System administrator.