summaryrefslogtreecommitdiffabout
authorSergey Poznyakoff <gray@gnu.org.ua>2018-02-05 21:06:43 (GMT)
committer Sergey Poznyakoff <gray@gnu.org.ua>2018-02-05 21:13:17 (GMT)
commit245a89645fead857aa1ca18c0d10d72e03e3746f (patch) (side-by-side diff)
tree021c01b39a9221fe185f8bbdb445288a233f5b1f
parent3eff9532e5116eab0b465c356fc798ec62e16df7 (diff)
downloadvarnish-mib-245a89645fead857aa1ca18c0d10d72e03e3746f.tar.gz
varnish-mib-245a89645fead857aa1ca18c0d10d72e03e3746f.tar.bz2
Version 3.0 (Varnish 5.2.1)release-3.0
* configure.ac: Raise version number. * NEWS: Update. * README: Update. * src/varnish-mib.8: Update.
Diffstat (more/less context) (ignore whitespace changes)
-rw-r--r--NEWS5
-rw-r--r--README4
-rw-r--r--configure.ac18
-rw-r--r--src/betab.c4
-rw-r--r--src/varnish-mib.82
5 files changed, 12 insertions, 21 deletions
diff --git a/NEWS b/NEWS
index e447533..ecb0dc0 100644
--- a/NEWS
+++ b/NEWS
@@ -3,6 +3,11 @@ See the end of file for copying conditions.
Please send Varnish-mib bug reports to <gray@gnu.org>
+Version 3.0, 2018-02-05
+
+Supports Varnish 5.2.1 only.
+
+
Version 2.0, 2018-02-05
This version is written for Varnish 5.2.0. It will definitely not
diff --git a/README b/README
index ea78317..f9083ed 100644
--- a/README
+++ b/README
@@ -25,8 +25,8 @@ of Varnish API version it is written for:
1.0, 1.1 Varnish 4.0 and 4.1
1.2 Varnish 4.0, 4.1, 5.1
- 2.0 (this release) Varnish 5.2.0
- 3.0 Varnish 5.2.1
+ 2.0 Varnish 5.2.0
+ 3.0 (this release) Varnish 5.2.1
* Installation
diff --git a/configure.ac b/configure.ac
index 917bab5..c9506a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@
# along with Varnish-mib. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.69)
-AC_INIT([varnish-mib], 2.0, [gray@gnu.org])
+AC_INIT([varnish-mib], 3.0, [gray@gnu.org])
AC_CONFIG_SRCDIR(src/varnish_mib.mib2c)
AM_CONFIG_HEADER(config.h)
AC_CONFIG_AUX_DIR([build-aux])
@@ -43,21 +43,7 @@ AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
# Checks for Varnish
-PKG_CHECK_MODULES([VARNISHAPI], [varnishapi >= 5.0])
-
-check_minor_number() {
- if [ "$2" -gt 1 ]; then
- AC_MSG_ERROR([Unsupported Varnish API version; please try varnish_mib 3.0 or newer])
- fi
-}
-
-v=$($PKG_CONFIG --modversion varnishapi)
-if test -n "$v"; then
- save_IFS=$IFS
- IFS='.'
- check_minor_number $v
- IFS=$save_IFS
-fi
+PKG_CHECK_MODULES([VARNISHAPI], [varnishapi >= 5.2.1])
# Check for Net-SNMP
AC_PATH_PROG([NET_SNMP_CONFIG], net-snmp-config, none, $PATH)
diff --git a/src/betab.c b/src/betab.c
index 83d77e3..768503a 100644
--- a/src/betab.c
+++ b/src/betab.c
@@ -15,8 +15,8 @@
along with varnish-mib. If not, see <http://www.gnu.org/licenses/>.
*/
#include "varnish_mib.h"
-#include <varnish/vas.h>
-#include <varnish/vqueue.h>
+#include <vas.h>
+#include <vqueue.h>
#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>
diff --git a/src/varnish-mib.8 b/src/varnish-mib.8
index 71e7abc..6458321 100644
--- a/src/varnish-mib.8
+++ b/src/varnish-mib.8
@@ -28,7 +28,7 @@ loaded into
.BR snmpd (8)
as shown above (actual path can of course differ, depending on how
the package was configured). This version is written for Varnish
-\fB5.2.0\fR.
+\fB5.2.1\fR.
.PP
The values in the OID branches
.BR client ,

Return to:

Send suggestions and report system problems to the System administrator.