aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-04-21 16:04:01 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2009-04-21 16:09:41 +0300
commiteb0b1eef83ca77da145264c81631299ffc4cc574 (patch)
tree60d62365877e47a6d80e15ef4b42430171b34e62 /configure.ac
parentdbc2333c048514d0bbdade8a680c3933c7dc79a4 (diff)
downloadtagr-eb0b1eef83ca77da145264c81631299ffc4cc574.tar.gz
tagr-eb0b1eef83ca77da145264c81631299ffc4cc574.tar.bz2
Use "grecs" submodule for configuration parsing.
* Makefile.am (ACLOCAL_AMFLAGS): Add -I grecs/am. (SUBDIRS): grecs (ChangeLog): New rule. * ChangeLog: Rename to ChangeLog.svn * doc: Rename to etc. * etc/upgrade.awk: New file. * bootstrap.conf: Initialize "grecs". * configure.ac: Call GRECS_SETUP. (AC_CONFIG_FILES): Add grecs/Makefile and grecs/src/Makefile. * gnulib.modules: Add gitlog-to-changelog and sysexits. * src/Makefile.am (LDADD, INCLUDES): Add grecs. (AM_CPPFLAGS): Define additional variables. * src/log.c (use_stderr): Remove. Use log_to_stderr instead. (grecs_print_diag): New function. * src/main.c: Redo command-line support. (listen_sockaddr): New global. * src/readconfig.c: Rewrite. * src/tagr.h: Include sysexits.h and grecs.h (listen_sockaddr, log_to_stderr, pidfile): New externs. * src/main.c, src/stat.c, src/report.c: Use sysexits codes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 53d26ee..25a64c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# This file is part of tagr -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-# Copyright (C) 2000, 2005, 2008 Max Bouglacoff, Sergey Poznyakoff
+# Copyright (C) 2000, 2005, 2008, 2009 Max Bouglacoff, Sergey Poznyakoff
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -58,7 +58,9 @@ AC_CHECK_FUNCS([memset pow select socket strchr strdup strerror strtoul])
# GNUlib
gl_INIT
-
+
+GRECS_SETUP
+
# Check for gd headers and libraries
AC_CHECK_HEADERS([gd.h gdfonts.h],:,
[AC_MSG_ERROR([Libgd headers gd.h and/or gdfonts.h are not found])])
@@ -75,6 +77,10 @@ AC_CHECK_LIB([gdbm], [gdbm_open],
,
[AC_MSG_ERROR([libgdbm not found])])
-AC_CONFIG_FILES([Makefile gnu/Makefile src/Makefile])
+AC_CONFIG_FILES([Makefile
+ gnu/Makefile
+ grecs/Makefile
+ grecs/src/Makefile
+ src/Makefile])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.