aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e5fc376..aa3ee22 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Smap.
-# Copyright (C) 2010, 2014 Sergey Poznyakoff
+# Copyright (C) 2010, 2014, 2019 Sergey Poznyakoff
#
# Smap is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -35,9 +35,15 @@ libsmap_la_SOURCES = \
tracestr.c\
url.c\
vasnprintf.c\
- wordsplit.c\
xscript.c
+nodist_libsmap_la_SOURCES = \
+ wordsplit.c\
+ wordsplit.h
+
+VPATH += $(srcdir)/wordsplit
+EXTRA_DIST = wordsplit/wordsplit.c wordsplit/wordsplit.h
+
libsmap_la_LDFLAGS = -version-info 0:0:0
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(srcdir)/wordsplit

Return to:

Send suggestions and report system problems to the System administrator.