aboutsummaryrefslogtreecommitdiff
path: root/modules/postgres/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2019-07-10 20:45:43 +0300
committerSergey Poznyakoff <gray@gnu.org>2019-07-10 20:49:33 +0300
commit6134242c5f804ee94856088f0258a20560c809fe (patch)
tree56f7191da2579ba57058ed3a602e7955a11b7d9f /modules/postgres/Makefile.am
parent9223032f5025f8bc4820dfdfb081be1c7fcd1c4e (diff)
downloadsmap-6134242c5f804ee94856088f0258a20560c809fe.tar.gz
smap-6134242c5f804ee94856088f0258a20560c809fe.tar.bz2
Use wordsplit from a submodule
* .gitmodules (wordsplit): New module. * configure.ac: Link lib/wordsplit/wordsplit.h to include/smap/wordsplit.h * include/smap/Makefile.am (pkginclude_HEADERS): Install wordsplit.h from submodule. * include/smap/wordsplit.h: Remove. * lib/wordsplit.c: Remove. * lib/Makefile.am: Access wordsplit sources from the submodule. * modules/echo/Makefile.am (AM_CPPFLAGS): Add -I$(top_builddir)/include * modules/guile/Makefile.am: Likewise. * modules/ldap/Makefile.am: Likewise. * modules/mailutils/Makefile.am: Likewise. * modules/mysql/Makefile.am: Likewise. * modules/postgres/Makefile.am: Likewise. * modules/sed/Makefile.am: Likewise. * src/Makefile.am: Likewise.
Diffstat (limited to 'modules/postgres/Makefile.am')
-rw-r--r--modules/postgres/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/postgres/Makefile.am b/modules/postgres/Makefile.am
index 13e05eb..1fd7827 100644
--- a/modules/postgres/Makefile.am
+++ b/modules/postgres/Makefile.am
@@ -21,4 +21,4 @@ mod_LTLIBRARIES=postgres.la
postgres_la_SOURCES = postgres.c
postgres_la_LIBADD = ../../lib/libsmap.la @POSTGRES_LIBS@
AM_LDFLAGS = -module -avoid-version -no-undefined
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include

Return to:

Send suggestions and report system problems to the System administrator.