aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2019-07-10 20:45:43 +0300
committerSergey Poznyakoff <gray@gnu.org>2019-07-10 20:49:33 +0300
commit6134242c5f804ee94856088f0258a20560c809fe (patch)
tree56f7191da2579ba57058ed3a602e7955a11b7d9f /lib/Makefile.am
parent9223032f5025f8bc4820dfdfb081be1c7fcd1c4e (diff)
downloadsmap-6134242c5f804ee94856088f0258a20560c809fe.tar.gz
smap-6134242c5f804ee94856088f0258a20560c809fe.tar.bz2
Use wordsplit from a submodule
* .gitmodules (wordsplit): New module. * configure.ac: Link lib/wordsplit/wordsplit.h to include/smap/wordsplit.h * include/smap/Makefile.am (pkginclude_HEADERS): Install wordsplit.h from submodule. * include/smap/wordsplit.h: Remove. * lib/wordsplit.c: Remove. * lib/Makefile.am: Access wordsplit sources from the submodule. * modules/echo/Makefile.am (AM_CPPFLAGS): Add -I$(top_builddir)/include * modules/guile/Makefile.am: Likewise. * modules/ldap/Makefile.am: Likewise. * modules/mailutils/Makefile.am: Likewise. * modules/mysql/Makefile.am: Likewise. * modules/postgres/Makefile.am: Likewise. * modules/sed/Makefile.am: Likewise. * src/Makefile.am: Likewise.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e5fc376..aa3ee22 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,3 +1,3 @@
# This file is part of Smap.
-# Copyright (C) 2010, 2014 Sergey Poznyakoff
+# Copyright (C) 2010, 2014, 2019 Sergey Poznyakoff
#
@@ -37,7 +37,13 @@ libsmap_la_SOURCES = \
vasnprintf.c\
- wordsplit.c\
xscript.c
+nodist_libsmap_la_SOURCES = \
+ wordsplit.c\
+ wordsplit.h
+
+VPATH += $(srcdir)/wordsplit
+EXTRA_DIST = wordsplit/wordsplit.c wordsplit/wordsplit.h
+
libsmap_la_LDFLAGS = -version-info 0:0:0
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(srcdir)/wordsplit

Return to:

Send suggestions and report system problems to the System administrator.