aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-06-07 01:07:00 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-06-07 01:07:00 +0300
commit769386224bd9df0ae8772b20d4d3f8fd743ff4f5 (patch)
treef95b67811f7b947c5a5f3f87ca6283998965bf5f /configure.ac
parent24dd694b5ad3dad1e8690eae895d11d3e826dbb1 (diff)
downloadsmap-769386224bd9df0ae8772b20d4d3f8fd743ff4f5.tar.gz
smap-769386224bd9df0ae8772b20d4d3f8fd743ff4f5.tar.bz2
Implement loadable modules. Add `echo' module.
* include/Makefile.am: New file. * include/smap/Makefile.am: New file. * include/smap/module.h: New file. * lib/Makefile.am: New file. * src/module.c: New file. * src/query.c: New file. * include/smap: New directory. * src/kwtab.h: Move to include/smap. * src/diag.h: Likewise. * src/ostr.h: Likewise. * src/wordsplit.h: Likewise. * lib: New directory. * src/kwtab.c: Move to lib * src/ostr.c: Likewise. * src/wordsplit.c: Likewise. * lib/diag.c: New file. * Makefile.am (SUBDIRS): Add include and lib * configure.ac: Update. * src/Makefile.am: Move installable headers to include/smap, libraries to lib. (smap_SOURCES): Add module.c, url.c, query.c. (AM_CPPFLAGS): Define SMAP_MODDIR. * src/log.c (smap_error_str, smap_debug_str) (smap_trace_str): Move to lib/diag.c (smap_verror, smap_error): Likewise. * src/smap.c (smap_kwtab): Add new keywords. (main): Initialize module subsystem. * src/smap.h: Update. * modules/Makefile.am: New file. * modules/echo/Makefile.am: New file. * modules/echo/echo.c: New file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ccb1a99..a0d4a82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,9 @@ AM_INIT_AUTOMAKE([1.11 gnits tar-ustar std-options silent-rules])
# Enable silent rules by default:
AM_SILENT_RULES([yes])
+dnl Global subst variables
+AC_SUBST(SMAP_MODDIR,'$(libdir)/$(PACKAGE)')
+
# Checks for programs.
AC_PROG_CC
AC_PROG_LN_S
@@ -91,6 +94,12 @@ if test "$status_tcpwrap" = "yes"; then
fi
AC_CONFIG_FILES([Makefile
- src/Makefile])
+ include/Makefile
+ include/smap/Makefile
+ lib/Makefile
+ src/Makefile
+ modules/Makefile
+ modules/echo/Makefile
+ ])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.