aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index fd22cbf..f56c663 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of SLB
-# Copyright (C) 2011 Sergey Poznyakoff
+# Copyright (C) 2011, 2015 Sergey Poznyakoff
#
# SLB is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -29,9 +29,9 @@ RENDITION = DISTRIB
MAKEINFOFLAGS=-D$(RENDITION)
-GENDOCS=gendocs.sh
+GENDOCS=$(srcdir)/gendocs.sh
-TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
+TEXI2DVI=texi2dvi -t '@set $(RENDITION)'
# Make sure you set TEXINPUTS.
# TEXINPUTS=/usr/share/texmf/pdftex/plain/misc/ is ok for most distributions
@@ -40,7 +40,7 @@ manual:
TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
- $(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual'
+ $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
# Checking
check-tabs:
@@ -107,7 +107,7 @@ check-config:
's/@deffnx\{0,1\} {Config} *\([^@, ]*\).*/\1/p' \
$(top_srcdir)/src/config.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
- $(info_TEXINFOS)
+ $(info_TEXINFOS)
check-sub-config:
@sed -n '/slb_kw\[\] *= *{/,/^}/{p}' ../src/config.c |tr '\n{' ' \n'|sed -n '/grecs_type_section/s/"\([^"]*\)".*grecs_type_section,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*, *\(.*\) *}.*/\1 \2/p' | \

Return to:

Send suggestions and report system problems to the System administrator.