summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-11-30 22:33:33 +0100
committerSergey Poznyakoff <gray@gnu.org.ua>2017-11-30 22:33:33 +0100
commit37edbef65e31a597cda1308c5f5341bd55f50bc6 (patch)
treea773c47943d594b355fb90551bc6ff886e527f13 /Makefile.PL
parenta14e7a93f2e6c164cde74cc2359c28312cc814d1 (diff)
downloadslackbuilder-37edbef65e31a597cda1308c5f5341bd55f50bc6.tar.gz
slackbuilder-37edbef65e31a597cda1308c5f5341bd55f50bc6.tar.bz2
Cleanup
* .gitignore: Update. * MANIFEST.SKIP: New file. * Makefile.PL: New file. * lib/SlackBuilder.pm: Set $VERSION * slackbuilder.pl: Rename to slackbuilder
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..90614b3
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,23 @@
+use strict;
+use ExtUtils::MakeMaker;
+use Module::Metadata;
+
+WriteMakefile(NAME => 'slackbuilder',
+ DISTNAME => 'slackbuilder',
+ VERSION_FROM => 'lib/SlackBuilder.pm',
+ AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
+ LICENSE => 'gpl_3',
+ ABSTRACT => 'Slackware Package Builder',
+ EXE_FILES => [ 'slackbuilder' ],
+ PREREQ_PM => {
+ HTML::Parser => '3.72',
+ LWP::UserAgent => '6.29',
+ List::Regexp => '1.03',
+ POSIX::Run::Capture => 0,
+ Scalar::Util => 0,
+ URI => 0,
+ JSON => 0
+ },
+ MIN_PERL_VERSION => 5.016001
+);
+

Return to:

Send suggestions and report system problems to the System administrator.