aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL23
1 files changed, 15 insertions, 8 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 29aa661..4aee252 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -15,8 +15,8 @@ WriteMakefile(
LIBS => [''], # e.g., '-lm'
DEFINE => '',
INC => '-I.', # e.g., '-I. -I/usr/include/other'
- OBJECT => '$(O_FILES) runcap/libruncap.a',
- DIR => [ 'runcap' ],
+ OBJECT => '$(O_FILES)',
+ MYEXTLIB => 'runcap/libruncap.a',
META_MERGE => {
'meta-spec' => { version => 2 },
resources => {
@@ -33,12 +33,6 @@ WriteMakefile(
package MY;
-sub pasthru {
- my $val = shift->SUPER::pasthru(@_);
- chomp($val);
- return $val . "\\\n O='\$(CCFLAGS)'";
-}
-
sub test {
my $val = shift->SUPER::test(@_);
open(my $fd, '<', \$val);
@@ -71,3 +65,16 @@ sub test {
return join("\n", @ret);
}
+
+sub postamble {
+'
+$(MYEXTLIB): runcap/configure
+ cd runcap && \
+ ./configure CFLAGS="$(CCFLAGS) $(CCCDLFLAGS)" && \
+ $(MAKE)
+
+runcap/configure: runcap/configure.ac
+ RUNCAP_BUILD=static autoreconf -f -i -s -I. runcap
+'
+}
+

Return to:

Send suggestions and report system problems to the System administrator.