aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-07-21 18:55:43 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2017-07-21 18:55:43 +0300
commitf0b082d3be6126ee0f6af85d9b51c31b4bc8c4d4 (patch)
tree5c65dd44ab69df67e7b60a56cd407a369104aa52 /Makefile.PL
parentec78df167efca7feba360b29700ef052eccf4b69 (diff)
downloadposixruncapture-f0b082d3be6126ee0f6af85d9b51c31b4bc8c4d4.tar.gz
posixruncapture-f0b082d3be6126ee0f6af85d9b51c31b4bc8c4d4.tar.bz2
Write more tests.
* runcap: Update. * Makefile.PL (test): Generate custom subdirs-test_ rules. * capture.c (capture_new): Fix type checking. * t/POSIX-Run-Capture.t: Rename to t/00use.t * t/01simple.t: New file. * t/02lines.t: New file. * t/03two.t: New file. * t/TestCapture.pm: New file.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 004a192..86b969f 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -46,7 +46,8 @@ sub test {
my $ignore;
while (<$fd>) {
chomp;
- if (/^subdirs-test_.*$/) {
+ if (/^(subdirs-test_.+?)\s*:.*$/) {
+ push @ret, "$1:: subdirs-test-prepare", '';
$ignore = 1;
} elsif ($ignore) {
if (/^$/) {
@@ -60,5 +61,11 @@ sub test {
}
}
close $fd;
+
+ push @ret, '',
+ "subdirs-test-prepare::",
+ "\t\@\$(MAKE) -C runcap/t genout O='\$(CCFLAGS)'",
+ '';
+
return join("\n", @ret);
}

Return to:

Send suggestions and report system problems to the System administrator.