aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-07-22 14:50:01 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2017-07-22 15:13:57 +0300
commit7f5cbd2332df055d8b9e365974f8743f82ad4886 (patch)
tree45a320169d046f5c2ae1ac533c7d9f916ab35608 /Makefile.PL
parent970d2e1f1c540b94443456bbdf1a8d315401b188 (diff)
downloadposixruncapture-7f5cbd2332df055d8b9e365974f8743f82ad4886.tar.gz
posixruncapture-7f5cbd2332df055d8b9e365974f8743f82ad4886.tar.bz2
Implement "input" key and set_input method.
* Capture.xs (capture_new): New keyword "input". (capture_set_input): New method. * MANIFEST: Update. * Makefile.PL: Add the 'check' goal (alias to 'test'). * capture.c (capture_new): Take input SV as 5th parameter. (capture_set_input): New function. (capture_DESTROY): Dereference input, if defined. * capture.h (capture) <input>: New method. (capture_new): Change signature. * t/08input.t: New file. * t/TestCapture.pm: Read content in BEGIN block, instead of hardcoding it. (TestCapture): $argv can be a hash or array ref. All uses changed.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 86b969f..29aa661 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -65,6 +65,8 @@ sub test {
push @ret, '',
"subdirs-test-prepare::",
"\t\@\$(MAKE) -C runcap/t genout O='\$(CCFLAGS)'",
+ '',
+ 'check: test',
'';
return join("\n", @ret);

Return to:

Send suggestions and report system problems to the System administrator.