aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c1d2b9..5a42270 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,7 +35,7 @@ AC_PROG_LEX
35# Checks for libraries. 35# Checks for libraries.
36 36
37# Checks for header files. 37# Checks for header files.
38AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h sys/time.h syslog.h unistd.h]) 38AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h sys/time.h syslog.h unistd.h utmp.h utmpx.h])
39 39
40# Checks for typedefs, structures, and compiler characteristics. 40# Checks for typedefs, structures, and compiler characteristics.
41AC_TYPE_UID_T 41AC_TYPE_UID_T
@@ -48,6 +48,18 @@ IU_CHECK_MEMBERS([struct msghdr.msg_control, struct msghdr.msg_accrights], , ,
48 [#include <sys/types.h> 48 [#include <sys/types.h>
49 #include <sys/socket.h>]) 49 #include <sys/socket.h>])
50 50
51IU_CHECK_MEMBERS([struct utmp.ut_tv, struct utmp.ut_name,
52 struct utmp.ut_user, struct utmp.ut_time,
53 struct utmp.ut_host], , ,
54 [#include <utmp.h>])
55
56if test "$ac_cv_header_utmpx_h" = yes; then
57 IU_CHECK_MEMBERS([struct utmpx.ut_tv, struct utmpx.ut_name,
58 struct utmpx.ut_user, struct utmpx.ut_time,
59 struct utmpx.ut_host], , ,
60 [#include <utmpx.h>])
61fi
62
51# Checks for library functions. 63# Checks for library functions.
52AC_FUNC_CHOWN 64AC_FUNC_CHOWN
53AC_FUNC_FORK 65AC_FUNC_FORK

Return to:

Send suggestions and report system problems to the System administrator.