aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 46 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae3a9c7..3a23a1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,12 +122,36 @@ AC_ARG_ENABLE([inetd],
[build and install a replacement for SBINDIR/inetd]),
[case $enableval in
yes) AC_SUBST([INETD], [inetd]);;
no) ;;
esac])
+sysvinit_status=maybe
+AC_ARG_ENABLE([sysvinit],
+ AC_HELP_STRING([--enable-sysvinit],
+ [compile the SystemV init support]),
+ [sysvinit_status=$enableval])
+
+if test $sysvinit_status = "maybe"; then
+ AC_TRY_COMPILE([#ifdef HAVE_UTMPX_H
+# include <utmpx.h>
+#else
+# include <utmp.h>
+#endif
+],
+[int x = RUN_LVL;],
+[sysvinit_status=yes],
+[sysvinit_status=no])
+fi
+
+test $sysvinit_status = "no"
+PIES_SYSVINIT_ENABLED=$?
+AC_DEFINE_UNQUOTED([PIES_SYSVINIT_ENABLED],[$PIES_SYSVINIT_ENABLED],
+ [whether SystemV init support is compiled])
+AM_CONDITIONAL([PIES_COND_SYSVINIT],[test $sysvinit_status = "yes"])
+
AH_BOTTOM([
# ifndef ATTRIBUTE_NORETURN
# define ATTRIBUTE_NORETURN __attribute__ ((__noreturn__))
# endif
])
@@ -144,12 +168,34 @@ IMPRIMATUR_INIT
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
+AC_CONFIG_COMMANDS([status],[
+cat <<EOF
+Configuration summary:
+
+URL of the control API ............................. $control_url
+PAM support ........................................ $status_pam
+SystemV initialization support ..................... $sysvinit_status
+EOF
+if test $sysvinit_status = "yes"; then
+ cat <<EOF
+URL of the SystemV init ............................ $sysvinit_control_url
+Emergency shell .................................... $emergency_shell
+EOF
+fi
+],
+[sysvinit_status=$sysvinit_status
+control_url=`echo "$DEFAULT_PIES_CONTROL_URL" | sed 's/\\\$/\\\\\$/g'`
+sysvinit_control_url=$DEFAULT_INIT_CONTROL_URL
+emergency_shell=$EMERGENCY_SHELL
+status_pam=$status_pam
+])
+
AC_CONFIG_FILES([Makefile
gnu/Makefile
lib/Makefile
src/Makefile
ident/Makefile
doc/Makefile

Return to:

Send suggestions and report system problems to the System administrator.