aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2016-03-19 14:58:27 +0200
committerSergey Poznyakoff <gray@gnu.org>2016-03-19 16:30:41 +0200
commitd6102982ae0e69a2c75cd2a499ba3909516cc0ae (patch)
tree054f8a27dc1eb92497d9bb357f2cde7f0d823fac /tests/Makefile.am
parent60b43ae490f52a783a34c8d77baaa695f7c32f01 (diff)
downloadpies-d6102982ae0e69a2c75cd2a499ba3909516cc0ae.tar.gz
pies-d6102982ae0e69a2c75cd2a499ba3909516cc0ae.tar.bz2
Add testsute
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..668fe5e
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,71 @@
1# This file is part of GNU Pies.
2# Copyright (C) 2008-2016 Sergey Poznyakoff
3#
4# GNU Pies is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by
6# the Free Software Foundation; either version 3, or (at your option)
7# any later version.
8#
9# GNU Pies is distributed in the hope that it will be useful,
10# but WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12# GNU General Public License for more details.
13#
14# You should have received a copy of the GNU General Public License
15# along with GNU Pies. If not, see <http://www.gnu.org/licenses/>.
16
17EXTRA_DIST = $(TESTSUITE_AT) testsuite package.m4 respawn retcode mailer
18DISTCLEANFILES = atconfig $(check_SCRIPTS)
19MAINTAINERCLEANFILES = Makefile.in $(TESTSUITE)
20
21## ------------ ##
22## package.m4. ##
23## ------------ ##
24
25$(srcdir)/package.m4: $(top_srcdir)/configure.ac
26 { \
27 echo '# Signature of the current package.'; \
28 echo 'm4_define([AT_PACKAGE_NAME], [@PACKAGE_NAME@])'; \
29 echo 'm4_define([AT_PACKAGE_TARNAME], [@PACKAGE_TARNAME@])'; \
30 echo 'm4_define([AT_PACKAGE_VERSION], [@PACKAGE_VERSION@])'; \
31 echo 'm4_define([AT_PACKAGE_STRING], [@PACKAGE_STRING@])'; \
32 echo 'm4_define([AT_PACKAGE_BUGREPORT], [@PACKAGE_BUGREPORT@])'; \
33 } >$(srcdir)/package.m4
34
35#
36
37## ------------ ##
38## Test suite. ##
39## ------------ ##
40
41TESTSUITE_AT = \
42 testsuite.at\
43 control.at\
44 respawn.at\
45 redirect.at\
46 ret-exec.at\
47 ret-notify.at\
48 version.at
49
50TESTSUITE = $(srcdir)/testsuite
51M4=m4
52
53AUTOTEST = $(AUTOM4TE) --language=autotest
54$(TESTSUITE): package.m4 $(TESTSUITE_AT)
55 $(AM_V_GEN)$(AUTOTEST) -I $(srcdir) testsuite.at -o $@.tmp
56 $(AM_V_at)mv $@.tmp $@
57
58atconfig: $(top_builddir)/config.status
59 cd $(top_builddir) && ./config.status tests/$@
60
61clean-local:
62 @test ! -f $(TESTSUITE) || $(SHELL) $(TESTSUITE) --clean
63
64check-local: atconfig atlocal $(TESTSUITE)
65 @$(SHELL) $(TESTSUITE)
66
67# Run the test suite on the *installed* tree.
68#installcheck-local:
69# $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
70
71

Return to:

Send suggestions and report system problems to the System administrator.