aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2015-12-31 13:59:18 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2015-12-31 15:58:17 +0200
commit00e6c3c3ed06a258a02943fc49fa7c528025d747 (patch)
tree52530660be48fb5f4611bcc9393886bab8a70b72 /lib/Makefile.am
parent7f204cc788de3e03a51087b1273deb5b59288cf2 (diff)
downloadpies-00e6c3c3ed06a258a02943fc49fa7c528025d747.tar.gz
pies-00e6c3c3ed06a258a02943fc49fa7c528025d747.tar.bz2
Command-line control interface.
* configure.ac (DEFAULT_CONTROL_URL): New subst variable. * grecs: Upgrade. * ident/pam.c (overwrite_and_free): Free ptr. * lib/Makefile.am: Add new sources. * src/addrfmt.c: Move to lib/addrfmt.c * lib/grecsasrt.c: New file. * lib/grecsasrt.h: New file. * lib/mkfilename.c: New file. * lib/netrc.c: New file. * lib/pp.c: New file. * lib/split3.c: New file. * src/url.c: Move from lib/url.c (pies_url_free_user, pies_url_free_passwd): New finctions. * lib/libpies.h (strsplit3): New proto. (pies_url_create, pies_url_destroy) (pies_url_get_arg, pies_url_copy) (pies_url_free_user, pies_url_free_passwd) (netrc_scan) (pp_add_option, pp_command_line, mkfilename) (sockaddr_to_str, sockaddr_to_astr): New protos * src/Makefile.am (bin_PROGRAMS): New program: piesctl (pies_SOURCES): Remove addrfmt.c and url.c. (noinst_HEADERS, BUILT_SOURCES): Add piesctl-cl.h * src/cmdline.opt: Use pp_* function family to build preprocessor command line. * src/ctl.c (http_header_hash): Use case-insensitive hashing. (ctlio_finalize_reply): Don't close connection after sending 401 response. (input): Remove ws and wsflags. All uses changed. (input_append): Use strsplit3 to parse the request line. * src/pies.c: Use pp_* function family to build preprocessor command line. Move assert_, mkfilename and _cb+_url functions into libpies. * src/pies.h (pies_sockaddr_storage): Move to libpies.h * src/piesctl.c: New file. * src/piesctl-cl.opt: New file.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 89812ca..a0d6614 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,3 +1,3 @@
# This file is part of GNU Pies.
-# Copyright (C) 2005, 2006, 2007, 2008, 2010, 2013 Sergey Poznyakoff
+# Copyright (C) 2005-2008, 2010, 2013, 2015 Sergey Poznyakoff
#
@@ -18,13 +18,26 @@ noinst_LIBRARIES=libpies.a
-noinst_HEADERS = libpies.h
+noinst_HEADERS = libpies.h grecsasrt.h
libpies_a_SOURCES=\
+ addrfmt.c\
arraymember.c\
+ grecsasrt.c\
+ mkfilename.c\
+ netrc.c\
parsetime.c\
proctitle.c\
- strtotok.c
+ pp.c\
+ split3.c\
+ strtotok.c\
+ url.c
-libpies_a_LIBADD=$(LIBOBJS)
+libpies_a_LIBADD=\
+ $(LIBOBJS)\
+ @GRECS_LDADD@
-AM_CPPFLAGS = -I$(top_srcdir)/gnu -I../gnu
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/gnu\
+ -I../gnu\
+ @GRECS_INCLUDES@\
+ -DDEFAULT_PREPROCESSOR="$(DEFAULT_PREPROCESSOR)"

Return to:

Send suggestions and report system problems to the System administrator.