aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-10-15 16:21:32 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2009-10-15 16:21:32 +0300
commitb713e2208519e7cba1c779cbd9387137eb101e5e (patch)
treec1245c09d9cffa5d74ec8961ed0ffd820f0bd23e /doc/Makefile.am
parent9dbe6b40d07df41255f0c8fda6895000b7c7e1a6 (diff)
downloadpies-b713e2208519e7cba1c779cbd9387137eb101e5e.tar.gz
pies-b713e2208519e7cba1c779cbd9387137eb101e5e.tar.bz2
Various fixes.
* README: Fix typo. * doc/usr-acl.texi: New file. * doc/Makefile.am (pies_TEXINFOS): Remove pies.texi, add usr-acl.texi (check-config, check-sub-config): Handle @deffnx * doc/pies.texi: Update. * src/Makefile.am (AM_CPPFLAGS): Remove superfluous defs, use ../gnu/configmake.h instead * src/acl.c (_acl_common_section_parser): Handle tag, depending on the value of `flag' parameter. Avoid coredumping on NULL pacl. (acl_section_parser, defacl_section_parser): Update calls to _acl_common_section_parser. * src/pies.c (STATEDIR): Replace with LOCALSTATEDIR. (GRECS_VALUE_IS_EMPTY): New define (possibly belongs to grecs more than to pies). (assert_grecs_value_type) (return_code_section_parser): Use GRECS_VALUE_IS_EMPTY to check for empty value. (_get_array_arg): Bugfix. (component_keywords, pies_keywords): Add missing docstrings. * src/progman.c (TYPE_RETR): Rename to TYPE_REDIRECTOR. All uses updated.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index fec8df3..bb2ff49 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -18,8 +18,8 @@ info_TEXINFOS=pies.texi
pies_TEXINFOS=\
fdl.texi\
macros.texi\
- pies.texi\
- rendition.texi
+ rendition.texi\
+ usr-acl.texi
EXTRA_DIST = \
check-docs.sh\
@@ -48,7 +48,7 @@ check-options:
check-config:
@check-docs.sh 'configuration statements' \
'/pies_keywords\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
- 's/@deffn {Config} *\([^@,]*\).*/\1/p' \
+ 's/@deffnx\{0,1\} {Config} *\([^@,]*\).*/\1/p' \
$(top_srcdir)/src/pies.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS)
@@ -58,7 +58,7 @@ check-sub-config:
while read ident kw; do \
check-docs.sh "$$ident configuration statements" \
"/$$kw"'\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
- "s/@deffn {Config: *$${ident}}"' *\([^@,]*\).*/\1/p' \
+ "s/@deffnx\{0,1\} {Config: *$${ident}}"' *\([^@,]*\).*/\1/p' \
$(top_srcdir)/src/pies.c $(top_srcdir)/src/acl.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS); \

Return to:

Send suggestions and report system problems to the System administrator.