aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-09-15 10:40:29 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2009-09-15 10:40:54 +0300
commit989a5bbb74c3620abaa2191ce2c4f8d5968dbf0a (patch)
treec0b2324a523905c3c17201cc2468c9078976fc74 /configure.ac
parentdbad35177723e19147ab49b59a3728e00fe05875 (diff)
downloadpies-989a5bbb74c3620abaa2191ce2c4f8d5968dbf0a.tar.gz
pies-989a5bbb74c3620abaa2191ce2c4f8d5968dbf0a.tar.bz2
Branch off from the Mailfromd project into a separate repository.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac97
1 files changed, 97 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..192fc53
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,97 @@
1# This file is part of Pies. -*- autoconf -*-
2# Copyright (C) 2009 Sergey Poznyakoff
3#
4# This program is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by
6# the Free Software Foundation; either version 3, or (at your option)
7# any later version.
8#
9# This program is distributed in the hope that it will be useful,
10# but WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12# GNU General Public License for more details.
13#
14# You should have received a copy of the GNU General Public License
15# along with this program. If not, see <http://www.gnu.org/licenses/>.
16# Process this file with autoconf to produce a configure script.
17
18AC_PREREQ([2.63])
19AC_INIT([pies], [1.0], [bug-mailfromd@gnu.org.ua])
20AC_CONFIG_SRCDIR([src/pies.h])
21AC_CONFIG_AUX_DIR([build-aux])
22AC_CONFIG_HEADERS([config.h])
23AM_INIT_AUTOMAKE([1.11 gnits tar-ustar dist-bzip2 std-options silent-rules])
24
25# Enable silent rules by default:
26AM_SILENT_RULES([yes])
27
28# Checks for programs.
29AC_PROG_CC
30gl_EARLY
31AC_PROG_MAKE_SET
32AC_PROG_RANLIB
33AC_PROG_YACC
34AC_PROG_LEX
35
36# Checks for libraries.
37
38# Checks for header files.
39AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h sys/time.h syslog.h unistd.h])
40
41# Checks for typedefs, structures, and compiler characteristics.
42AC_TYPE_UID_T
43AC_TYPE_MODE_T
44AC_TYPE_PID_T
45AC_TYPE_SIZE_T
46AC_TYPE_SIGNAL
47
48IU_CHECK_MEMBERS([struct msghdr.msg_control, struct msghdr.msg_accrights], , ,
49 [#include <sys/types.h>
50 #include <sys/socket.h>])
51
52# Checks for library functions.
53AC_FUNC_CHOWN
54AC_FUNC_FORK
55AC_CHECK_FUNCS([alarm dup2 gethostbyname isascii memmove memset select setenv socket strchr strcspn strtol strtoul sysconf getdtablesize])
56
57# Gnulib
58gl_INIT
59
60# **********************
61# Mailutils
62# **********************
63# FIXME
64AM_GNU_MAILUTILS(2.0, [mailer cfg argp], [:])
65
66# Test for setproctitle
67MF_PROCTITLE
68
69# Gettext.
70AM_ICONV
71AM_GNU_GETTEXT([external], [need-formatstring-macros])
72AM_GNU_GETTEXT_VERSION([0.17])
73
74# Doc hints.
75# Select a rendition level:
76# DISTRIB for stable releases (at most one dot in the version number)
77# and maintenance releases (two dots, patchlevel < 50)
78# PROOF for alpha releases.
79# PUBLISH can only be required manually when running make in doc/
80AC_SUBST(RENDITION)
81case `echo $VERSION|sed 's/[[^.]]//g'` in
82""|".") RENDITION=DISTRIB;;
83"..") if test `echo $VERSION | sed 's/.*\.//'` -lt 50; then
84 RENDITION=DISTRIB
85 else
86 RENDITION=PROOF
87 fi;;
88*) RENDITION=PROOF;;
89esac
90
91AC_CONFIG_FILES([Makefile
92 gnu/Makefile
93 lib/Makefile
94 src/Makefile
95 doc/Makefile
96 po/Makefile.in])
97AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.