aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-10-16 13:06:36 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2009-10-16 13:06:36 +0300
commite9950f2fa8e45e86396371e91443dc04f14fb5f2 (patch)
tree094e8dc99e049d8a515b963571c186d6cba366e2 /Makefile.am
parenta0631c9ac2c13c3ef1db027a490620504a287d3f (diff)
downloadpies-e9950f2fa8e45e86396371e91443dc04f14fb5f2.tar.gz
pies-e9950f2fa8e45e86396371e91443dc04f14fb5f2.tar.bz2
Implement -D and -U options (preprocessor control).
* Makefile.am (dist-hook,alpha,alphacheck): New rules. (ChangeLog): Be silent. * NEWS: Update. * doc/pies.texi: Update. * gnulib.modules: Add quote and quotearg * src/pies.c: Implement -D and -U options. Improve --help output. * src/pies.h: Include quotearg.h
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 67e64f3..0f97a90 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,22 @@ ACLOCAL_AMFLAGS = -I m4 -I am -I grecs/am
2 2
3SUBDIRS=gnu grecs lib src doc po 3SUBDIRS=gnu grecs lib src doc po
4 4
5dist-hook:
6 @PATCHLEV=`echo "$(PACKAGE_VERSION)" | \
7 sed -r "s/[0-9]+\.[0-9]+\.?//"`; \
8 if test $${PATCHLEV:-0} -lt 50; then \
9 if grep -q FIXME NEWS; then \
10 echo >&2 "NEWS file contains FIXMEs"; \
11 exit 1; \
12 fi; \
13 fi
14
15alpha:
16 $(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
17
18alphacheck:
19 $(MAKE) distcheck distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
20
5# Define the following variables in order to use the ChangeLog rule below: 21# Define the following variables in order to use the ChangeLog rule below:
6# prev_change_log [optional] Name of the previous ChangeLog file. 22# prev_change_log [optional] Name of the previous ChangeLog file.
7# gen_start_date [optional] Start ChangeLog from this date. 23# gen_start_date [optional] Start ChangeLog from this date.
@@ -12,7 +28,7 @@ changelog_dir = .
12 28
13.PHONY: ChangeLog 29.PHONY: ChangeLog
14ChangeLog: 30ChangeLog:
15 if test -d .git; then \ 31 @if test -d .git; then \
16 cmd=$(top_srcdir)/build-aux/gitlog-to-changelog; \ 32 cmd=$(top_srcdir)/build-aux/gitlog-to-changelog; \
17 if test -n "$(gen_start_date)"; then \ 33 if test -n "$(gen_start_date)"; then \
18 cmd="$$cmd --since=\"$(gen_start_date)\""; \ 34 cmd="$$cmd --since=\"$(gen_start_date)\""; \

Return to:

Send suggestions and report system problems to the System administrator.