aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-10-22 23:03:24 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2011-10-23 00:42:30 +0300
commit21ffba77b92f79a59c62728ede4ad7a4ecb5a0ee (patch)
treec3204285a3ba57d590d815c682f1113b6f48d834 /Makefile.am
parenteb8797c9a28f3f4e238bad89b56d331492df7828 (diff)
downloadpies-21ffba77b92f79a59c62728ede4ad7a4ecb5a0ee.tar.gz
pies-21ffba77b92f79a59c62728ede4ad7a4ecb5a0ee.tar.bz2
Switch to the latest Grecs.
* Makefile.am (ChangeLog): Use git2chg.awk to build it. * NEWS: Update. * bootstrap.conf (gnulib_modules): Grecs does not depend on gnulib any more. * configure.ac: Version 1.2.90. Define GRECS_HOST_PROJECT_INCLUDES, remove grecs Makefiles from AC_CONFIG_FILES: it is now done by GRECS_SETUP itself. * gnulib.modules (gitlog-to-changelog,argp): Remove. (configmake): New module. * grecs: Update to a52ab6c6. * lib/libpies.h: Remove redefinitions of _() and N_(). * src/Makefile.am: Update for the recent grecs. * src/acl.c: Rewrite using Grecs support for lists and symtabs. * src/acl.h: Likewise. * src/diag.c: Likewise. * src/inetd.c: Likewise. * src/meta1gram.y: Likewise. * src/meta1lex.h: Likewise. * src/meta1lex.l: Likewise. * src/pies.c: Likewise. * src/pies.h: Likewise. * src/progman.c: Likewise. * src/userprivs.c: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 12 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index b3c49a2..de4bf81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
1# This file is part of GNU Pies. 1# This file is part of GNU Pies.
2# Copyright (C) 2008, 2009, 2010 Sergey Poznyakoff 2# Copyright (C) 2008, 2009, 2010, 2011 Sergey Poznyakoff
3# 3#
4# GNU Pies is free software; you can redistribute it and/or modify 4# GNU Pies is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by 5# it under the terms of the GNU General Public License as published by
@@ -34,37 +34,19 @@ alpha:
34alphacheck: 34alphacheck:
35 $(MAKE) distcheck distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"` 35 $(MAKE) distcheck distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
36 36
37# Define the following variables in order to use the ChangeLog rule below: 37# Name of the previous ChangeLog file.
38# prev_change_log [optional] Name of the previous ChangeLog file.
39# gen_start_date [optional] Start ChangeLog from this date.
40# changelog_dir [mandatory] Directory where to create ChangeLog
41prev_change_log = ChangeLog.mfd 38prev_change_log = ChangeLog.mfd
39# Start Git ChangeLog from this date.
42gen_start_date = 2009-09-04 40gen_start_date = 2009-09-04
43changelog_dir = .
44 41
45.PHONY: ChangeLog 42.PHONY: ChangeLog
46ChangeLog: 43ChangeLog:
47 @if test -d .git; then \ 44 $(AM_V_GEN)if test -d .git; then \
48 cmd=$(top_srcdir)/build-aux/gitlog-to-changelog; \ 45 git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' | \
49 if test -n "$(gen_start_date)"; then \ 46 awk -f $(top_srcdir)/@GRECS_SUBDIR@/build-aux/git2chg.awk \
50 cmd="$$cmd --since=\"$(gen_start_date)\""; \ 47 -vsince=\"$(gen_start_date)\" -vappend=\"$(prev_change_log)\" \
51 fi; \ 48 > ChangeLog.tmp; \
52 $$cmd --format='%s%n%n%b%n' | \ 49 cmp ChangeLog ChangeLog.tmp > /dev/null 2>&1 || \
53 sed '/<unknown>$$/d' | fmt -s > $(changelog_dir)/cl-t; \ 50 mv ChangeLog.tmp ChangeLog; \
54 if test -n "$(prev_change_log)" && test -f "$(prev_change_log)"; \ 51 rm -f ChangeLog.tmp; \
55 then \
56 echo "" >> $(changelog_dir)/cl-t; \
57 cat "$(prev_change_log)" | \
58 sed '/^Local Variables:/,/^End:/d' >> $(changelog_dir)/cl-t; \
59 fi; \
60 echo "Local Variables:" >> $(changelog_dir)/cl-t; \
61 echo "mode: change-log" >> $(changelog_dir)/cl-t; \
62 echo "version-control: never" >> $(changelog_dir)/cl-t; \
63 echo "buffer-read-only: t" >> $(changelog_dir)/cl-t; \
64 echo "End:" >> $(changelog_dir)/cl-t; \
65 echo "" >> $(changelog_dir)/cl-t; \
66 sed -n '1,/^[^#]/s/^#//p' $(top_srcdir)/Makefile.am \
67 >> $(changelog_dir)/cl-t; \
68 rm -f $(changelog_dir)/ChangeLog; \
69 mv $(changelog_dir)/cl-t $(changelog_dir)/ChangeLog; \
70 fi 52 fi

Return to:

Send suggestions and report system problems to the System administrator.