aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 17 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 0b5c6d5..f2f416b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,37 +17,35 @@
AUTOMAKE_OPTIONS = gnits 1.8
ACLOCAL_AMFLAGS = -I m4 -I imprimatur
+SUBDIRS = \
+ imprimatur\
+ doc\
+ examples\
+ lib\
+ pam_sql\
+ pamck
+
if PAM_COND_FSHADOW
- FSHADOW_DIR=pam_fshadow
+ SUBDIRS += pam_fshadow
endif
if PAM_COND_REGEX
- REGEX_DIR=pam_regex
+ SUBDIRS += pam_regex
endif
if PAM_COND_LOG
- LOG_DIR=pam_log
+ SUBDIRS += pam_log
endif
if PAM_COND_LDAPHOME
- LDAPHOME_DIR=pam_ldaphome
+ SUBDIRS += pam_ldaphome
endif
if PAM_COND_UMOTD
- UMOTD_DIR=pam_umotd
+ SUBDIRS += pam_umotd
endif
if PAM_COND_GROUPMEMBER
- GROUPMEMBER_DIR=pam_groupmember
+ SUBDIRS += pam_groupmember
+endif
+if PAM_COND_INNETGR
+ SUBDIRS += pam_innetgr
endif
-SUBDIRS = \
- imprimatur\
- doc\
- examples\
- lib\
- $(FSHADOW_DIR)\
- $(REGEX_DIR)\
- $(LOG_DIR)\
- pam_sql\
- $(LDAPHOME_DIR)\
- $(UMOTD_DIR)\
- $(GROUPMEMBER_DIR)\
- pamck
EXTRA_DIST=ChangeLog.svn

Return to:

Send suggestions and report system problems to the System administrator.