aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2018-08-12 19:20:04 +0300
committerSergey Poznyakoff <gray@gnu.org>2018-08-12 19:20:04 +0300
commit6bba235d667f25a9ae6bcd1c560b0ae28ea16505 (patch)
tree0d9e26952d7ae381f7dd78e6954fdda366a9eed7 /configure.ac
parent23b718d2a385bb07bcbd4584a694e9e75050098b (diff)
downloadpam-modules-6bba235d667f25a9ae6bcd1c560b0ae28ea16505.tar.gz
pam-modules-6bba235d667f25a9ae6bcd1c560b0ae28ea16505.tar.bz2
New module pam_innetgr.
* Makefile.am: Add new module. * NEWS: Upgrade * configure.ac: Add configuration for pam_innetgr * pam_innetgr/Makefile.am: New file. * pam_innetgr/pam_innetgr.c: New file. * doc/Makefile.am: Add pam_innetgr.8 * doc/pam-modules.texi: Document pam_innetgr. * doc/pam_innetgr.8: New file. * examples/ldappubkey: Bugfixes (publickeyattribute setting): Accept a list of attributes (publickeyfilter): New setting.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0a4eb33..6869248 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@
AC_PREREQ(2.63)
-AC_INIT(pam-modules, 2.2, bug-pam-modules@gnu.org.ua)
+AC_INIT(pam-modules, 2.2.90, bug-pam-modules@gnu.org.ua)
AC_CONFIG_SRCDIR(pam_fshadow/pam_fshadow.c)
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
@@ -171,6 +171,18 @@ yes)
esac
])
+#
+AC_CHECK_FUNCS([getdomainname])
+PM_ENABLE(innetgr,[
+case $build_innetgr in
+probe)
+ AC_CHECK_FUNC([innetgr],[build_innetgr=yes],[build_innetgr=no])
+ ;;
+yes)
+ AC_CHECK_FUNC([innetgr],[],[AC_MSG_ERROR([cannot build the requested module pam_innetgr because function innetgr is not present in libc])])
+ ;;
+esac])
+
## *****************
## debugging support
## *****************
@@ -219,7 +231,7 @@ delim="-------------------------------------------------------------------"
echo $delim | tr '-' '*'
echo "Modules to build:"
res=
-for module in fshadow regex log pgsql mysql ldaphome umotd groupmember
+for module in fshadow regex log pgsql mysql ldaphome umotd groupmember innetgr
do
modname=pam_$module
eval enable=\${build_$module}
@@ -242,7 +254,8 @@ build_pgsql=$build_pgsql
build_mysql=$build_mysql
build_ldaphome=$build_ldaphome
build_umotd=$build_umotd
-build_groupmember=$build_groupmember])
+build_groupmember=$build_groupmember
+build_innetgr=$build_innetgr])
AC_OUTPUT(Makefile
doc/Makefile
@@ -255,4 +268,5 @@ AC_OUTPUT(Makefile
pam_ldaphome/Makefile
pam_umotd/Makefile
pam_groupmember/Makefile
+ pam_innetgr/Makefile
pamck/Makefile)

Return to:

Send suggestions and report system problems to the System administrator.