aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-05-13 09:48:57 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2012-05-13 09:48:57 +0000
commit1a80b647d6d40f7ce39afb2575ea5d8f9766f9da (patch)
tree1b3b70b849f27b102623b29e0f71381c4ca67312 /configure.ac
parent993eff136613ba7964bd3747630cf06ced3d940c (diff)
downloadpam-modules-1a80b647d6d40f7ce39afb2575ea5d8f9766f9da.tar.gz
pam-modules-1a80b647d6d40f7ce39afb2575ea5d8f9766f9da.tar.bz2
Revamp build system. Add pam_ldaphome module.
* configure.ac: Test for ldap. (AC_OUTPUT): Create pam_ldaphome/Makefile. * acinclude.m4 (PM_ENABLE): Declare PAM_COND_<item> conditional in addition to BUILD_PAM_<item> substitution variable. * Makefile.am (SUBDIRS): Include most modules via conditionally defined Makefile variables. * lib/graypam.h (gray_env): New struct. (gray_env_get,gray_env_free,gray_env_read) (gray_boolean_true_p): New protos. * lib/env.c: New file. * lib/Makefile.am (libgraypam_la_SOURCES): Add env.c * pam_fshadow/Makefile.am: Remove BUILD_PAM_FSHADOW substitution. * pam_regex/Makefile.am: Remove BUILD_PAM_REGEX substitution. * pam_sql/pam_sql.c (free_config, boolean_true_p) (read_config): Remove. Use gray_env_* functions instead. All uses updated. * pam_regex/pam_regex.c: Fix typo. * pam_ldaphome/Makefile.am: New file. git-svn-id: file:///svnroot/pam-modules/trunk@118 56984be4-0537-0410-a56c-fcb268c96130
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 3cff92c..737f191 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,12 +30,6 @@ AC_SUBST(VI_CURRENT,1)
AC_SUBST(VI_REVISION,0)
AC_SUBST(VI_AGE,0)
-dnl Modules
-build_fshadow=probe
-build_regex=probe
-build_log=probe
-build_pgsql=probe
-
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
@@ -153,6 +147,14 @@ AC_SUBST(MYSQLLIBS)
AC_SUBST(PGSQLLIBS)
AC_SUBST(SQL_MODULES)
+# LDAP support
+PM_ENABLE(ldaphome)
+if test $build_ldaphome = probe; then
+ AC_CHECK_LIB(ldap, ldap_bind,
+ [build_ldaphome=yes]
+ [build_ldaphome=no])
+fi
+
## *****************
## debugging support
## *****************
@@ -196,7 +198,7 @@ delim="-------------------------------------------------------------------"
echo $delim | tr '-' '*'
echo "Modules to build:"
res=
-for module in fshadow regex log pgsql mysql
+for module in fshadow regex log pgsql mysql ldaphome
do
modname=pam_$module
eval enable=\${build_$module}
@@ -216,7 +218,8 @@ build_fshadow=$build_fshadow
build_regex=$build_regex
build_log=$build_log
build_pgsql=$build_pgsql
-build_mysql=$build_mysql])
+build_mysql=$build_mysql
+build_ldaphome=$build_ldaphome])
AC_OUTPUT(Makefile
doc/Makefile
@@ -225,4 +228,5 @@ AC_OUTPUT(Makefile
pam_regex/Makefile
pam_log/Makefile
pam_sql/Makefile
+ pam_ldaphome/Makefile
pamck/Makefile)

Return to:

Send suggestions and report system problems to the System administrator.